Community
cancel
Showing results for 
Search instead for 
Did you mean: 
WShep1
New Contributor I
1,234 Views

Quartus 20.1 NIOS II ED error: Makefile:1010: recipe for target '***.elf' failed

I have just migrated from 18.1 to 20.1 Lite.  I am working on a W10 machine and have installed WSL, Ubuntu, etc.  NIOS II SBT is running and I was able to create a new project from template as instructed.  I created a project using the "Small Hello World" template.  The application and bsp projects were created.  Cleaning and building the bsp project works well as does clean the application project.  However, when I try to build the application project, I get the following error -

10:03:31 **** Build of configuration Nios II for project test_20_1_7 ****
wsl make all
wslpath: hal_bsp: No such file or directory
Info: Building /mnt/c/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp/
make --no-print-directory -C /mnt/c/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp/
[BSP build complete]
Info: Compiling hello_world_small.c to obj/default/hello_world_small.o
nios2-elf-gcc.exe -xc -MP -MMD -c -IC:/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp/HAL/inc -IC:/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp -IC:/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp/drivers/inc -pipe -D__hal__ -DALT_NO_C_PLUS_PLUS -DALT_NO_CLEAN_EXIT -D'exit(a)=_exit(a)' -DALT_NO_EXIT -DALT_USE_DIRECT_DRIVERS -DALT_NO_INSTRUCTION_EMULATION -DALT_USE_SMALL_DRIVERS -DSMALL_C_LIB -DALT_SINGLE_THREADED -Os -g -Wall -mno-hw-div -mno-hw-mul -mno-hw-mulx -mgpopt=global -o obj/default/hello_world_small.o hello_world_small.c
Info: Linking test_20_1_7.elf
nios2-elf-g++.exe -T'C:/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp/linker.x' -msys-crt0='C:/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp/obj/HAL/src/crt0.o' -msys-lib= -LC:/a_Nightowl/wds2hdmi/rtl/qsys/software/test_20_1_7_bsp -msmallc -Wl,-Map=test_20_1_7.map -Os -g -Wall -mno-hw-div -mno-hw-mul -mno-hw-mulx -mgpopt=global -o test_20_1_7.elf obj/default/hello_world_small.o -lm -msys-lib=m
nios2-elf-g++.exe: error: missing argument to '-msys-lib='
make: *** [test_20_1_7.elf] Error 1
Makefile:1010: recipe for target 'test_20_1_7.elf' failed

10:03:34 Build Finished (took 2s.438ms)

 

I have no idea what this error means.  Can any one help me?

9 Replies
Patrick77
Novice
1,029 Views

Hi WShep1,

      Have you figured out the problem? Since I met same problem as yours, may I know your final solution please? Thanks in advance.

WShep1
New Contributor I
1,023 Views

Hi Patrick77,

Yes, I was able to get the NIOS II 20.1  to work after a 1.5 month running email dialog with Intel Premire support.  However, I am not sure that I can tell you in 7 easy steps all of the steps forwards and backwards that we went through to arrive at it working.   The vey best advice that I can give you is if at all possible continue to use 18.1 until such time as Intel gets their act together and makes the NIOS II software work.  It was after 18.1 that Intel switched over to using WSL/Ubuntu with the NIOS II software and this is when all of the problems began.  If you are not able to use 18.1 for whatever reason must use 20.1, then I suggest trying to tap into Intel Premire Support.  While I don't have direct access to Intel Premire Support, I was able to tap into them via my local (Arizona) Arrow Intel FAE.  If the above doesn't work for you, I can send you a condensed transcript of my email communications with Intel Premire Support, but be forewarned it is a lot of thrashing around which eventually got it working for me.

Good Luck,

Bill Sheppard

wdsheppard@earthlink.net

 

Patrick77
Novice
1,007 Views

Hi Bill,

Thanks for your quick response and I really appreciate your advice. When I when back to use version 18.1, most of the problem just disappearred. I don't think I need a Intel Premire Support for now but I hope they can release a more stable version next time.

Thank you again for your time. Wish you good luck.

Nikhilnh
Beginner
803 Views

Hello WShep1,

I am also facing the same issue. But I cannot go back to quartus 18.1. I am currently using 19.2 and it would be helpful if you share the solution or the transcript of your email with Intel premire support also helps. 

Looking forward to your reply.

Thanks,

Nikhil  N H

WShep1
New Contributor I
798 Views

I have created the following document of the steps that I took.  There are several assumptions in this document that assume you know how to do certain things like create a xxxx.sopcinfo file.  If you have any questions about it, I will try to answer them. 

I have only tested these steps in 20.1 and 20.1.1, but I believe that this is the same problem in 19.2.  Let me know if it works for you in 19.2.

Good Luck

Bill

Jesper
Beginner
466 Views

Hi!
I have tried to delete the Makefile, update WSLENV and run create_this_app but get the following error:

Required $SOPC_KIT_NIOS2 Environmental Variable is not set!

 

Do you have any ideas?

WShep1
New Contributor I
455 Views

I am sorry, but I don't know what the error you are getting means.  The only suggestion that I can make is to be sure and use the GUI as outlined in my instruction document instead of any command line commands.  I have only seen this process work using the GUI.  I haven't tested it with the Eclipse SBT for NIOS command line tools.

 

Jesper
Beginner
445 Views

Thanks for your reply!

I opened the NIOS II command shell as described in your document and it worked.

This approach does not seem to work when using the Ubuntu or WSL prompt.

Sadly, your document is just a "hack" to make it work and does not solve the bug above. How ever, i appreciate your effort!

WShep1
New Contributor I
437 Views

I agree that it is a sad situation that Intel has not fixed this problem yet.  They are fully aware of it as I got the information contained in my document last summer and the problem is still with us as of Quartus 20.1.1.  I don't know if the new version, 21.1 (which I believe is only available in the Pro Version), has the problem fixed or not as I am using the Lite version and 20.1.1 is the latest Lite version available.

Reply