Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Quartus 4.2 and UBoot

Honored Contributor I

Hi All, 

Has anyone noticed/experienced any problems when moving a UBoot build from 

Quartus 4.1/Nios 1.0 to Quartus 4.2/Nios1.1 ? 


Only I've got a system that was working fine under the earlier versions, however 

after upgrading and rebuilding the sof UBoot fails to correctly boot out of the epcs. 

However if I just do a nios-download on the uboot elf it runs fine (just not out of 

the epcs). I've noticed that the epcs peripheral size has changed (registers now at base + 0x200) 

and have updated this but can't see any other differences.  





p.s. Obviously I've cleaned the uboot tree with a distclean and completely rebuilt it but to 

no avail.
0 Kudos
2 Replies
Honored Contributor I

Further to this it seems I can't manually get any code programmed into the epcs to work. 

My epcs should contain the sof and uboot (or a test application) 

I carry out the following tasks to program the files into the epcs: 


@echo "Converting UBoot elf to FLASH file" elf2flash --epcs --base=0x0 --end=0x7fffffff --flash=U59 --input=u-boot.elf      --output=u-boot.flash --boot=boot_loader_epcs.srec @echo "Programming UBoot into EPCS on default JTAG device" nios2-flash-programmer --epcs --input=u-boot.flash --sof=alteradk_flash_programmer.sof   @echo "Converting FPGA SOF to FLASH file" sof2flash --epcs --flash=U59 --offset=0x0  --input=full_featured.sof --output=full_featured.flash @echo "Programming SOF into EPCS on default JTAG device" nios2-flash-programmer --relocate --epcs --input=full_featured.flash --sof=__NO_SOF_PLEASE__ 


Now this sequence is adapted from an earlier one that definitely worked (just updated with the new features such as __NO_SOF_PLEASE__) 


however when I reboot the fpga it successfully loads the sof and configures but point blank refuses to 

run my code. (I've also tried a simple non-hosted led flasher with no success either) 

Yet if I download uboot or the led program via nios2-download -g both programs work correctly. 


So does anyone have any suggestions as to what has changed in the epcs boot sequence that 

could be affecting my design? 


Thanks in advance!,  

(getting slightly desperate now)
Honored Contributor I

The EPCS bootloader code changed in 4.2 to make it smaller, and I believe there is also a patch. 

Search the errata: (