Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

RUN_ON_HDL_SIMULAGTOR_ONLY xxxx.elf error 1

Altera_Forum
Honored Contributor II
1,237 Views

https://skydrive.live.com/redir?resid=e0ed7271c68be47c!361 

 

i follow the example googled, finished CPU with other components with SOPC, in eclipse 

 

when i open the project to build project again it said RUN_ON_HDL_SIMULAGTOR_ONLY xxxx.elf error 1 

then i build BSP again and build project again, it become make all complete then i remember to make clean, it got the error again and then build again 

however, no matter what i do, i turn on or off switch, it only light turn on, and never off
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
109 Views

There are a couple things to check here: 

 

1. Instead of following the toggle switch. You can flip back and forth between 0/1. Make sure to put enough wait cycles in the while loop to ensure the rate it's flashing at is visible to you.  

 

2. Did you have the pin assignment of the LED pin going to the designated LED in Quartus? Vice versa for the switch pin. Good luck. 

 

 

 

--- Quote Start ---  

https://skydrive.live.com/redir?resid=e0ed7271c68be47c!361 

 

i follow the example googled, finished CPU with other components with SOPC, in eclipse 

 

when i open the project to build project again it said RUN_ON_HDL_SIMULAGTOR_ONLY xxxx.elf error 1 

then i build BSP again and build project again, it become make all complete then i remember to make clean, it got the error again and then build again 

however, no matter what i do, i turn on or off switch, it only light turn on, and never off 

--- Quote End ---  

Altera_Forum
Honored Contributor II
109 Views

i use pin assignment in lab exercise, i guess the tutorial i follow is to assign switch to LED, why need to add sleep to wait in while loop?

Reply