Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

Remote System Debug over Ethernet Cyclone V / Arria V

Altera_Forum
Honored Contributor II
992 Views

Hello 

 

I am wondering if someone was able to port the Example how to get the  

Remote System Debug over Ethernet with the Arria 10 to on Arria V / Cyclone V ? 

 

Link to the Example: 

http://rocketboards.org/foswiki/view/projects/remotesystemdebug 

 

An Application Note about this: 

https://www.altera.com/content/dam/altera-www/global/en_us/pdfs/literature/an/an_693.pdf 

 

Regards 

 

Stefan
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
135 Views

Which part of the implementation are you having trouble with?

Altera_Forum
Honored Contributor II
135 Views

I patched the kernel used in this Instruction http://rocketboards.org/foswiki/view/documentation/yoctodorabuildwithmetaaltera 

with the DebugHub drivers from here http://rocketboards.org/foswiki/view/projects/remotesystemdebug 

The result is https://github.com/nopeppermint/meta-altera which points to https://github.com/nopeppermint/linux-socfpga/tree/socfpga-3.10-ltsi 

=> so I used git clone git://github.com/nopeppermint/meta-altera.git instead of git clone git://github.com/kraj/meta-altera.git 

in this Instruction http://rocketboards.org/foswiki/view/documentation/yoctodorabuildwithmetaaltera 

 

=> I followed the Yocto build instructions and added this step: 

"bitbake -c menuconfig virtual/kernel" to select "Device Drivers/Character Devices/SLD HUB driver" so the driver was compiled. 

I manual added the mmlink application to the rootfs. 

 

=> in Qsys a "SLD Hub Controller System" is added 

 

=> the problem is somewhere between step 5-7 here http://rocketboards.org/foswiki/view/projects/remotesystemdebug as there is no connection :-( 

 

Do you have any suggestions/ideas ?
Altera_Forum
Honored Contributor II
135 Views

 

--- Quote Start ---  

the problem is somewhere between step 5-7 

--- Quote End ---  

 

Means the server is started, system console can be selected in signal tap but you don't get "JTAG ready"? 

 

I would check if the sever is connecting and responding by wireshark. If connecting but not responding check the embedded code. If responding but no valid JTAG communication, check the SLD_Hub connection.
Reply