Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12437 Discussions

Simple socket server example ---> unable to find working interfaces

Altera_Forum
Honored Contributor II
1,027 Views

Hello, 

 

I started working with Altera Stratix 4 GX development board recently. I am trying to run the simple socket server example (nios 2 ethernet standard example - https://www.altera.com/support/support-resources/design-examples/intellectual-property/embedded/nios...).  

 

Reading from other posts I was able to build and compile it with static IP. I changed the BSP to disable DHCP. When I run it on the board, it seems not to recognize the Ethernet interface.  

 

It says:  

prepped 0 interfaces, initializing... 

inet setup error: unable to find any working interfaces 

panic: IP 

dtrap - needs breakpoint 

 

Can anyone give a hint to where should I look to debug this? Or what should I do? 

 

Thank You, 

Sud 

0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
136 Views

Hi all, 

 

I found that Altera no longer supports the NicheStack TCP/IP Stack - Nios II Edition.  

 

https://www.altera.com/support/support-resources/knowledge-base/solutions/fb172438.tablet.html 

 

Is there any other alternative to buying the license?  

 

If someone else faced the same problem as me and solved it.. let me know.
Reply