Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,083 Views

SimpleSocketServer - No free buffers for rx

hi,  

 

I'm trying to run the SimpleSocketServer program in Eclipse. At the moment I'm getting some error messages when trying to run the program eg: 

 

([MicroC/OS-II]: Expanded Diagnosis: Failed to create SSSLEDLightshowsem...No free Buffers for rx etc..) Please take a look at the attachment for further details. 

 

I tried removing a single UART in my SOPC design and re-generate SOPC and compiling the QuartusII project, and that helped make the error messages go away. Still, I need to make the design work when I re-attach the UART in SOPC, can anyone provide some pointers ? 

 

Could this possibly have something to do with the number of IRQ providers that are connected to the NiosII in SOPC, there are 14 of them when I remove one of the UARTs in the design. 

 

regards, 

 

saber890
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
171 Views

Hi, 

 

from what I can see there have been previous threads on similar issues. From reading the http://alteraforums.com/forum/showthread.php?t=31901 thread I tried: 

 

1. Increasing the receive depth of the TSE_MAC from 2048x32 bits to 8192x32 bits, but that did not help. 

 

2. Increasing the MAXBIGPKT and NUMBIGBUFS from 30 to 512 in the "ipport.h" file, only delays the time it takes before the "no free buffers for rx" is displayed on the Nios II Console.  

 

The SSSLEDLightshowSem error messages persist and there is a delay before the DHCP aquired IP address is displayed on the NiosII Console(the delay is shorter when having removed a single UART in the SOPC design.  

 

The removal of a single UART some how also avoids the SSSLedLightshowSem error messages and let me run the SSS application).  

 

Also, I noticed that If I try pinging the socket server between the time the DHCP aquired IP address is printed to the Nios II Console and the "Simple Socket Server starting up" message, the socket server is replying  

 

Some pointers would be nice  

 

Saber890
Altera_Forum
Honored Contributor I
171 Views

Did you find how to solve this problem ? I have the same right now

Reply