Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

Slow response when debugging software

Altera_Forum
Honored Contributor II
870 Views

I use a cyclone IV custom board and use the NIOS ii soft processor. My question is when I step over a variable operation, i have to wait for 1 to 2 seconds, when I step over a function, I have to wait for 3 to 6 seconds to wait the run cursor to move to the next line. and sometimes when I step over a variable, it jumps to near by code line and then jump back. Is that normal?  

 

my computer is a thinkpad x230(i7-3520M, 8G RAM 256g SSD), I think it is fast enough for debugging software, and the software is windows 7 64bit + quartus 14.1. the NIOS II soft processor run at 100MHz. and I use on-chip memory. I use the "Nios II 14.1 Software Build Tools for Eclipse" to debug software. I have tried DE0-nano kit, and DE1-SOC kit, the demonstrations project. It is the same, very slow response, have to spend a lot of time on debugging software. Is this normal? Can I easily do something to improve debug speed?
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
128 Views

 

--- Quote Start ---  

and sometimes when I step over a variable, it jumps to near by code line and then jump back. Is that normal?  

 

--- Quote End ---  

 

This could be pretty normal if you are debugging code build in Release mode , i.e. with optimization enabled (-O3) and no ALT_DEBUG. 

Also make sure the running application is updated with the latest source code changes.
Reply