Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12410 Discussions

Suddenly "Processor is already paused" appear

Altera_Forum
Honored Contributor II
880 Views

Hi, 

 

I got a running system with a Nios II Core, LCD Character, LEDs (PIO), SDRAM, Intervall Timer, System ID, OnChip, clock, JTAG_UART. Now I added a SPI Interface and it stopped to work so I deleted the Interface again. The Problem now is that my system doesn't work anymore. If I want to load my C-File in the NIOS IDE on my board the following message promt: 

 

Using cable "USB-Blaster [USB-0]", device 1, instance 0x00 

Processor is already paused 

Reading System ID at address 0x20081048: verified 

Initializing CPU cache (if present) 

OK 

 

Downloading 20000000 ( 0%) 

Downloading 20008798 (79%) 

Downloaded 34KB in 0.6s (56.6KB/s) 

 

Verifying 20000000 ( 0%) 

Verifying 20008798 (79%) 

Verified OK  

Starting processor at address 0x200001B4 

 

My first try to solve the problem was deleting the SDRAM because I found some Issues where it was told that it could depend on the SDRAM. But it didn't help. The same error exist. The point is that the system worked before and i don't know if i change something and I don't recognize it.  

My second try was to make the NIOS II tutorial again and it works but there is no SDRAM in the system.  

What I can do is to rebuild my system again but I want to know how to get the problem fixed. 

So I appreciate a solution from somebody!!! 

 

Regards!
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
145 Views

Did you by any chance remove the input to reset_n?

Altera_Forum
Honored Contributor II
145 Views

Hi, 

 

I just set my reset_n to "1" that the reset has no effect any more.  

I also just reabuild my the whole system and it worked but I´m suspect the clock assignment because I tried it ,in my new design, with 125Mhz and it didn't work. So I adjusted the frequency to 50MHz and it worked. For this reason I tried the same at my old design but it didn't work.  

But I'm appreciate more hintes!
Reply