Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12383 Discussions

System works in debugger but not alone

Altera_Forum
Honored Contributor I
771 Views

How to troubleshoot following problem: 

 

I have a system with an external RAM and Flash memory. I run very simple blinker software which scrolls LEDs on the board. Also, I hooked up two other LEDs to memory read/write signals to see if something is active on the memory bus. 

 

I have configured cpu to boot from external flash and set the exception address in the ram. I have also configured IDE to place code and data into ram. 

 

When I run Debugger from IDE - everything is fine: I can set breakpoints, step over the code, or even remove all breakpoints and just resume full speed. 

 

When I program the flash with the same code and cycle power my software DOES NOT WORK. I see very short activity on my read/write LEDs but after a second ot two activity stops and the actual application never tooks off - LEDs do not flash. 

 

I hooked up Quartus and loaded fpga via JTAG in order to signaltap it - the same happens. On the signal tap I see no activity on ram/flash after short time just after RESET - this confirms what I see: read/write LEDs do not flash.  

 

Something is wrong, but since everything works in debugger I am not sure how to aproach the problem. Any ideas?
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
65 Views

check your pinout (or your bdf)

Reply