Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

U-boot problem using 3C120

Altera_Forum
Honored Contributor II
792 Views

Hi , 

 

Devboard: 3C120 

OS: UClinux 

Up: NIOS2 

 

I have followed the instruction in this link "alterawikiDOTcom_wiki_DasUBoot" to implement UBOOT. I have run the defualt with no problem using (nios2-generic.h and custom_fpga.h).. 

 

when I try to do this procedure for 3C120 according to this link "alterawikiDOTcom_wiki_ guide to 3c120 with u-boot"... I always get this error: 

"altera_pio.c:77: error: 'LED_PIO_WIDTH' undeclared here (not in a function)" . 

 

I have tried to diff the custom_fpga.h and 3c120_fpga.h and I see the different naming convetions on the PIO.. I have tried to comment them out but still gave me error.. 

See attchment please.. 

Hope someone could help me.. I have too far on this project prelims.. I have to get this uboot working because the product will be encapsulated and would be very much appreciated if we could programm the chip externall without opening the product..
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
70 Views

Could you upload your "custom_fpga.h" File?

Altera_Forum
Honored Contributor II
70 Views

Hi Raul, 

 

I have already resolve the problem.. thanks for the reponse anyway..
Reply