Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12367 Discussions

Uart returning -1 when more than 1 uart opened in NIOS

Altera_Forum
Honored Contributor I
912 Views

hi, 

 

I am using quartus 9.0.  

 

and I need to use 5 uart cores in sopc (all 115200). when i am opening one uart in blocking mode in Nios, it reads/writes fine. bt wen i start opening other uarts, the same port starts returning -1 (only opening of other ports,no reading no writing). 

 

I need to use all rs-232 ports..wat can be the problem? 

 

sth like this 

 

main() 

uart1=open(uart1_name, mode) 

uart2=(uart2_name, mode) 

 

 

 

result=read(uart2, buffer, len) //gives error if uart1 is opened before uart2, alone it works fine. 

 

 

 

 

I need to use all 5 rs-232 ports..wat can be the problem?:confused: 

can we use only one uart core??:confused: 

 

plz reply.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
57 Views

my problem is still not solved... plz helppppp......

Altera_Forum
Honored Contributor I
57 Views

If you post your question in the correct forum then you'll probably get better help. Moving to the Nios II forum....

Reply