Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
787 Views

Ubuntu 16.04 + Quartus Lite 17: problem removing JTAGD

Hi everybody, 

 

A couple of months ago I purchased a DE10-standard dev kit and I would like to use it in my graduation project (which is starting in 2 weeks from now); I am not an expert on Linux but I'm using Ubuntu flavors since a couple of years now. I have successfully installed Quartus 17 on my Ubuntu 16.04 and the program itself seems to work fine. The only thing that won't work is the programmer, i.e. I can make what I want but the Quartus programmer just does not "see" the USB blaster, no matter how I start the program (as user or root). I have been reading lots of messages on this topic and I followed the instructions to set the udev rules correctly; removing Quartus and reinstalling does not seem to work as well. I have been diving a little deeper in the JTAGD server that the programmer starts: in attached screenshot of my terminal is visible that there is a JTAGD process running, despite the fact that I have removed everything from my system (apparently I have not removed everything otherwise the process would not be there right?); when I start the programmer manually, a second JTAGD process (started as root) is added to the output in the attachement. Maybe the disfunctionality rootcause lays here? Anyway, I am a bit at the end of my knowledge and capabilities at the moment so I hope that there is an expert who can help me on this and give me directions on how to solve this. It would be a very unfortunate situation if I cannot use the board. 

 

Many thanks in advance to those who will be able to help me out! 

 

Best regards, 

Richard
0 Kudos
0 Replies
Reply