Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12368 Discussions

Unable to add BSP after subversion switch

Altera_Forum
Honored Contributor I
780 Views

Hello there, 

 

I have a Nios2-Project running for a while now, and do organize my code with subversion. There's everything checked in, even the project settings and .metadata from eclipse. Yesterday I switched to a branch for the first time with this project and now i cannot specify a Nios BSP and so i do get the following compiler error  

make all makefile:312: *** Edit Makefile and provide a value for BSP_ROOT_DIR. Stop.  

 

I even switched back to my original location. 

Now every time i open the Project Properties->Nios2 Application Properties every field is blank. So i can specify the BSP but if i close the properties and reopen, everything is gone. So it seems, that there is a Problem writting to the settings. 

 

Does anybody know, which file is used by eclipse to stroe these settings, so maybe i'll just delete it. 

 

My Configuration: 

Win7 64Bit 

Nios EDS 12.0.178 

I run Eclipse as administrator 

 

Thanks
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
68 Views

Hi there, 

it's me again: 

 

So after i got rid of the daily madness at work, i got a few more minutes to spend on the problem: 

I fond that in the makefile the following: 

ACTIVE_BUILD_CONFIG := default BUILD_CONFIGS += default BUILD_CONFIGS += Release include $(ACTIVE_BUILD_CONFIG)_config.mk 

 

was reduced to: 

ACTIVE_BUILD_CONFIG := default BUILD_CONFIGS += default  

 

So that the default_config.mk wasn't used anymore, which is btw the file which holds all the Nios Application Properties. 

 

So now i do have to figure out, why this was lost. It may be, that my colleague, who created the svn branch, does have an older version, which do not use these _config.mk 

 

But anyway, iam glad it works now!
Reply