Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12434 Discussions

Unable to run SoCEDSSetup-14.0.0.200-linux.run install app.

Altera_Forum
Honored Contributor II
1,763 Views

I am unable to run SoCEDSSetup-14.0.0.200-linux.run, this is on an ubuntu 3.2.0-63-generic-pae# 95-Ubuntu SMP Thu May 15 23:26:11 UTC 2014 i686 i686 i386 GNU/Linux. 

I have chmod +x to the file and I am root. The error is "cannot execute binary file" 

 

Has anyone else had this porblem and how was it resolved? 

 

Thanks
0 Kudos
13 Replies
Altera_Forum
Honored Contributor II
187 Views

found to be a 64bit/32bit problem, dropped back to previous release

Altera_Forum
Honored Contributor II
187 Views

So you dropped back to 13.1 ??? 

I have a same problem. I just install xubuntu 14.04 64 bit only because of this and now I am facing 32bit lib dependency problems :/
Altera_Forum
Honored Contributor II
187 Views

I tried 13.1, and it still does not work. The file does not even open. 

 

Any ideas?
Altera_Forum
Honored Contributor II
187 Views

I have done some tryouts and what worked for me was: 

13.1 on Xubuntu 12.04 32bit 

14.0 on Xubuntu 12.04 64bit 

14.0 on Xubuntu 14.04 64bit 

 

An as you said $chmod +x <file> 

and than sudo ./<file> 

And what was output from 13.1 on your machine?
Altera_Forum
Honored Contributor II
187 Views

For Linux you really need to check the install instructions. There are several libraries that are not installed in Linux by default that the Altera tools need. I think they have to do with running 32 bit apps built for older versions. Also, I don't think Ubuntu is a supported Linux distro for the Altera tools although I've heard that people have gotten it to work. I personally use Centos (based on redhat) and the tools work fine.

Altera_Forum
Honored Contributor II
187 Views

If you would like to use Ubuntu based distro with Altera 14.0 and above, I would reccommend 12.04 64bit because you are able to install ia32-libs package (has been replaced by lib32z1 lib32ncurses5 lib32bz2-1.0 from Ubuntu 13.04) and you get all you need basically. Otherwise you have to install all missing packages by  

$ sudo apt-get install package:i386 

And at the end of installation you should get a listing if you are missing some of the libraries.
Altera_Forum
Honored Contributor II
187 Views

I installed Ubuntu 12.04 over 6 mo. ago using instructions from http://rocketboards.org/foswiki/documentation/gsrd131gettingstartedyocto#obtaining_yocto_source_pack... and it went smooth as cream, including sudo apt-get install ia32-libs. Now trying to setup new laptop with Ubuntu 12.04 (as stated on the aforementioned Rocketboards page, so I assume it is supported by Altera tools Galfonz) using the same rocketboard instructions - this time sudo apt-get install ia32-libs is not available. As a result, SoCEDSSetup-14.1.0.186-linux.run does not run. 

 

I tried sudo apt-get install package:i386, but get 'unable to locate that package'. If anyone knows what to try next I would appreciate it.
Altera_Forum
Honored Contributor II
187 Views

Seems strange. I know it's matter of course but are you sure you installed 64bit version??? Otherwise try to search why are you not able to install 32bit libraries.

Altera_Forum
Honored Contributor II
187 Views

Did a complete reinstall of 32 bit Ubuntu 12.04, just in case with all my messing around some wires got crossed. 

 

Verified it is 32 bit from >Settings 

 

Installed the update, upgrade, etc. listed under Getting Started with Yocto - Ubuntu 12.04 on the RocketBoard.org page (http://www.rocketboards.org/foswiki/documentation/gsrd131gettingstartedyocto

 

Did not install the ia32-libs, because as I understand it, it is only needed for 64 bit installs 

 

Downloaded the the SoC EDS. Comes as a .run 

 

Did a chmod +x, on it, tried to run, (i.e. ./SoCEDS ...), get a "cannot execute binary file" 

 

Tried >sudo ./SoCEDS...run , got Syntax error: "(" unexpected 

 

From what I can Google, the "(" Syntax error has something to bash vs. dash, so I ran 

 

>sudo bash ./SoCEDS...run, and I get "cannot execute binary file" 

 

Did a few permutations, i.e. sometimes with ,/, sometimes no sudo, always with bash, but result always "cannot execute binary file". 

 

Redid the first few install steps - no difference, because everything already was installed.  

 

Tried to install ia32-libs, but would not install ... which I expected. Same with package:i386 

 

Most searched responses have chmod +x fixing the issue. I ran >ls -l and saw that the file attributes had x set. (-rwxrwxr-x) 

 

Any advice most appreciated.
Altera_Forum
Honored Contributor II
187 Views

 

--- Quote Start ---  

Did a complete reinstall of 32 bit Ubuntu 12.04, just in case with all my messing around some wires got crossed. 

 

Verified it is 32 bit from >Settings 

 

Installed the update, upgrade, etc. listed under Getting Started with Yocto - Ubuntu 12.04 on the RocketBoard.org page (http://www.rocketboards.org/foswiki/documentation/gsrd131gettingstartedyocto

 

Did not install the ia32-libs, because as I understand it, it is only needed for 64 bit installs 

 

Downloaded the the SoC EDS. Comes as a .run 

 

Did a chmod +x, on it, tried to run, (i.e. ./SoCEDS ...), get a "cannot execute binary file" 

 

Tried >sudo ./SoCEDS...run , got Syntax error: "(" unexpected 

 

From what I can Google, the "(" Syntax error has something to bash vs. dash, so I ran 

 

>sudo bash ./SoCEDS...run, and I get "cannot execute binary file" 

 

Did a few permutations, i.e. sometimes with ,/, sometimes no sudo, always with bash, but result always "cannot execute binary file". 

 

Redid the first few install steps - no difference, because everything already was installed.  

 

Tried to install ia32-libs, but would not install ... which I expected. Same with package:i386 

 

Most searched responses have chmod +x fixing the issue. I ran >ls -l and saw that the file attributes had x set. (-rwxrwxr-x) 

 

Any advice most appreciated. 

--- Quote End ---  

 

 

To clarify - this is with the 14.1 EDS (SoCEDSSetup-14.1.0.186-linux.run), not the 14.0 version in the title of this thread
Altera_Forum
Honored Contributor II
187 Views

Installed Ubuntu 12.04 64 bit - now I can launch SoCEDSSetup-14.1.0.186-linux.run. The Quartus stuff did not install (permission issues), but I'm not interested in FPGA just yet. Found that I had to run ../(ESD_Workspace)/embedded/ds-5_installer/Install.sh after SoCEDSSetup-14.1.0.186-linux.run to complete the install (you need to run Install.sh as root). 

 

Another interesting note - Install.sh would not run without errors until I accepted all the defaults. The only default I had tried to change was the location of the tools - I have a dual boot workstation and I was trying to put as much as I could in the FAT32 partition I set up for sharing (it is by far the largest). The default location is in Linux root partition (EXT4) and that seems to be required. So now whenever I run ANY script from Altera I accept all the defaults, because I suspect they don't test much other than that.
Altera_Forum
Honored Contributor II
187 Views

Good to know you make it run. Strange thing is they require 64bit distro with 32bit libraries...

Altera_Forum
Honored Contributor II
187 Views

as i heard only certain version of ubuntu is good to go for SOCEDS.

Reply