Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12437 Discussions

Video Out/VGA Display Skipping Every Other X Pixel

Altera_Forum
Honored Contributor II
834 Views

Hey, so I'm using a De1-SoC and programming in Assembly using the the Nios II instruction set found here: https://www.altera.com/content/dam/altera-www/global/en_us/pdfs/literature/hb/nios2/n2cpu_nii51017.p... 

So I was just experimenting with the video out pixel buffer (at memory located 0x8000000) and tried to create a screen that was just entirely white. I looped through each pixel and coloured each one white but I am getting vertical lines that are not being coloured in. I have provided pictures as well as screenshots of the documentation I used to create the image, my source code, and the output on my VGA monitor. 

 

http://www.alteraforum.com/forum/attachment.php?attachmentid=11935&stc=1 Vertical columns not being printed white 

http://www.alteraforum.com/forum/attachment.php?attachmentid=11937&stc=1 Video Out Documentation - 1 

http://www.alteraforum.com/forum/attachment.php?attachmentid=11938&stc=1 Video Out Documentation - 2 

http://www.alteraforum.com/forum/attachment.php?attachmentid=11936&stc=1 Video Out Documentation - 3 

 

Any help is greatly appreciated! Cheers
0 Kudos
0 Replies
Reply