Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,371 Views

Wishbone

Thanks for making the distribution for ucLinux for Nios II available! I've had a cyclone dev. kit here for over a year and haven't got round to using it (playing with it!), maybe I'll have a go now. Just need that familier blue & white box to arrive from altera with goodies in it! 

 

I noticed that you are trying to encourage users to post their own IP, my question is does anybody out there have a wishbone to avalon "block" to allow "easy" usage of IP from opencores? 

 

Thanks. 

 

Adrian
0 Kudos
6 Replies
Altera_Forum
Honored Contributor I
112 Views

wow, just looked at your website too (microtronix), looks like I'll be buying a uKit when they are available. 

 

I've just looked and shipping to the UK is $88, ouch! I'm assuming that is UPS or something, are there any other shipping methods? (like USPS) 

 

Adrian
Altera_Forum
Honored Contributor I
112 Views

Adac, 

 

Can't comment on your Microtronix question, but Wishone 2 Avalon is EASY!... slaves can be hooked up using the interface to user-logic wizard in SOPC Builder (take a quick look at the wishbone spec and avalon and you'll see what I mean; there is a 1:1 mapping for most signals). Masters may require a bit (couple lines of HDL) of logic to get things talking. I'll spare the deatil for now; a consultant friend and I ported the 10/100 ethernet MAC core from opencores to work with Nios a couple years ago. I'll try to dust it off and post it in the other forum for sharing IP in a day or two. Its a great example as it has both master and slave ports.
Altera_Forum
Honored Contributor I
112 Views

Thanks for taking the time to reply! I'd certainly be interested in seeing a working example. I've read in other places how easy it can be to interface wishbone to avalon, I think I actually tried to interface the i2c core as a test, but I came across a lack of compatible signals (i2c was a master peripheral). 

 

Adrian
Altera_Forum
Honored Contributor I
112 Views

 

--- Quote Start ---  

originally posted by adac@May 23 2004, 11:24 AM 

wow, just looked at your website too (microtronix), looks like i'll be buying a ukit when they are available. 

 

i've just looked and shipping to the uk is $88, ouch!  i'm assuming that is ups or something, are there any other shipping methods? (like usps) 

 

adrian 

--- Quote End ---  

 

 

Hello, 

 

Glad to hear you like our uKit. We are working to get distributors to carry this product in Europe (most likely EBV). Hopefully we'll be able to get something rolling by July.  

 

In the meantime let me know if you have any other questions. 

 

Best regards, 

Robert 

 

Manager, Sales and Marketing 

Microtronix
Altera_Forum
Honored Contributor I
112 Views

Thanks for getting back. EBV are an altera dealer (hence the reason for you using them), only problem with EBV is that you have to be a registered company/have account to purchase from them, this makes it impossible for individuals to buy stuff from them, given the price point of your kit you may want to look into the possibility of another dealer who could handle such things - looks like I'll have to purchase direct from you anyway. 

 

Thanks, 

 

Adrian
Altera_Forum
Honored Contributor I
112 Views

Hi Adac, 

 

Well I dusted off the core but it doesn't work! I need to go in and do some debugging; its likely that I have a pin assignment wrong or something (I have a daughter card with 10/100 PHY).... not too surprising as I haven't used it in a while, and a lot of tool changes have happened in that time (although it did work great and I'd had a web server running, did throughupt tests, etc.). So, unfortunately this will have to wait until I get through a couple other more pressing issues. However, I am happy to email you the files personally (I just don't want to post something to the board until it works)... email me if you want jkempa --at-- altera --dot--- com and I'll send it your way. 

 

Oh by the way, the failure was when my MAC driver software went out to talk to the external PHY on my daughter card; I can talk to the MAC core okay...so I am leaning in the direction of a bad pin assignment or HW failure on this one!
Reply