Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
773 Views

alt_flash_open_dev() returns 0

I've been using a CFI flash, S29GL....  

I'm able to access its contents through Memory read utility in the IDE, and also write into it correctly through Flash Programmer utility.. 

But, alt_flash_open_dev() always returns 0!  

I'm running this on Quartus 10.1 SP1.  

Pls help!
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
42 Views

Did you call alt_flash_open_dev with the exact device name provided by system.h? 

Memory read works since all CFI flash start in read mode and all have the same sram-like interface. 

Instead, alt_flash_open_dev() accesses the cfi specific functions and assumes you are targeting the correct device.
Altera_Forum
Honored Contributor I
42 Views

 

--- Quote Start ---  

Did you call alt_flash_open_dev with the exact device name provided by system.h? 

Memory read works since all CFI flash start in read mode and all have the same sram-like interface. 

Instead, alt_flash_open_dev() accesses the cfi specific functions and assumes you are targeting the correct device. 

--- Quote End ---  

 

 

Yes.. I'm calling the fn with exact name.... Gave "/dev/flash_name" too.. Doesn't work :(
Altera_Forum
Honored Contributor I
42 Views

Pradeep, I have had the same issue of alt_flash_open_dev() returning 0 all the time. I had enabled reduced drivers in the bsp settings. I do not know if you have it enabled or not. If you do not have it enabled, this solution might not apply to you. But if you do, try disabling them for a quick check.

Altera_Forum
Honored Contributor I
42 Views

 

--- Quote Start ---  

Pradeep, I have had the same issue of alt_flash_open_dev() returning 0 all the time. I had enabled reduced drivers in the bsp settings. I do not know if you have it enabled or not. If you do not have it enabled, this solution might not apply to you. But if you do, try disabling them for a quick check. 

--- Quote End ---  

 

Hi Baljeet 

i've not set reduced drivers flag!
Reply