Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,555 Views

configuration problem in programmer

Hello everyone,  

I actually have some problem about programming FPGA in programmer. 

When I connect the FPGA in my Quartus, it detect FPGA and I don't have neither compilation problems 

I have also done hardware setup and add file  

But when I press start, the progress is failed immediately. 

I've checked different voltage in my FPGA connection, like TDI= 3.3V TMS=3.3V TDo= 3.3V TCK=0V it seems it's correct, but when I download the program in  

FPGA, it seems these voltage don't react (I think TCK, TDI and TDO should react). 

Could anyone help me. I've spend a lot of time in this problem 

 

thanks you very much.
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
29 Views

do you program sof file to the device? check nconfig signal. if nconfig remain low, fpga remains reset.

Altera_Forum
Honored Contributor I
29 Views

thank you for u reply, I've program sof file. How could I check, nconfig signal?

Altera_Forum
Honored Contributor I
29 Views

What development board are you using? Your own design or a commercial one? 

 

What programmer are you using? An Altera USB Blaster, or something else? 

 

The more info you can provide about your setup (when you ask the question) the better the answer(s) you will get.
Altera_Forum
Honored Contributor I
29 Views

If you cannot download even sof file, you need to check power, POR(power on reset) condition is different on device. So check relevant power. And I cannot under stand TCK is not toggling, TCK is input from JTAG. The schematic for JTAG is correct?

Reply