Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
758 Views

eclipse dont show nios perspective

Hello people, 

 

Im having problems to start eclipse-nios2 on Opensuse 13.2, using quartus 13.1. Always i try call eclipse-nios2 from my laptop it only load INDIGO eclipse and dont show any perspective NIOS II. 

 

 

Here a log contain a debug from NIOS: 

 

# ./eclipse-nios2 -Debug 

 

Start VM: /home/REDBEAR/altera/13.1/quartus//linux/jre/bin/java 

-Dosgi.requiredJavaVersion=1.5 

-XX:MaxPermSize=256m 

-Xms40m 

-Xmx384m 

-Dosgi.user.area=@user.home/.altera.sbt4e/13.1.0.162 

-Dosgi.configuration.area=@user.home/.altera.sbt4e/13.1.0.162/configuration 

-Dosgi.configuration.cascaded=true 

-Dosgi.instance.area.default=@user.home/sbt4e-13.1-workspace 

-jar /home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar 

-os linux 

-ws gtk 

-arch x86 

-showsplash 

-launcher /home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/eclipse 

-name Eclipse 

--launcher.library /home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so 

-startup /home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar 

--launcher.overrideVmargs 

-exitdata 1c98004 

-product org.eclipse.epp.package.cpp.product 

-Debug 

-perspective com.altera.sbtgui.ui.cPerspective 

-vm /home/REDBEAR/altera/13.1/quartus//linux/jre/bin/java 

-vmargs 

-Dosgi.requiredJavaVersion=1.5 

-XX:MaxPermSize=256m 

-Xms40m 

-Xmx384m 

-Dosgi.user.area=@user.home/.altera.sbt4e/13.1.0.162 

-Dosgi.configuration.area=@user.home/.altera.sbt4e/13.1.0.162/configuration 

-Dosgi.configuration.cascaded=true 

-Dosgi.instance.area.default=@user.home/sbt4e-13.1-workspace 

-jar /home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar  

Configuration location: 

file:/home/REDBEAR/.altera.sbt4e/13.1.0.162/configuration/ 

Configuration file: 

file:/home/REDBEAR/.altera.sbt4e/13.1.0.162/configuration/config.ini loaded 

Install location: 

file:/home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/ 

Configuration file: 

file:/home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/configuration/config.ini loaded 

Shared configuration location: 

file:/home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/configuration/ 

Framework located: 

file:/home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/plugins/org.eclipse.osgi_3.7.2.v20120110-1415.jar 

Framework classpath: 

file:/home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/plugins/org.eclipse.osgi_3.7.2.v20120110-1415.jar 

Splash location: 

/home/REDBEAR/altera/13.1/nios2eds/bin/eclipse_nios2/plugins/org.eclipse.platform_3.7.2.v201202080800/splash.bmp 

Debug options: 

file:/home/REDBEAR/altera/13.1/nios2eds/bin/.options not found 

Time to load bundles: 11 

Starting application: 3103 

Application Started: 12503# 

 

 

Any help could be very good.
0 Kudos
0 Replies
Reply