Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

found.srec not detected

Altera_Forum
Honored Contributor II
3,546 Views

Hi, 

 

I was working on testing some things on the NIOS II on a DE2 board. It was working fine when I ran it as hardware. Suddenly it stopped working and this error message would flash in the console 

 

 

c:\altera\11.0\nios2eds\bin\gnu\H-i686-mingw32\bin\nios2-elf-objcopy.exe: 'Found': No such file Found.srec: Unable to open input file rm: cannot remove `Found.srec': No such file or directory 

 

I am using quartus 11.0 and have re-installed it once. Any ideas?
0 Kudos
7 Replies
Altera_Forum
Honored Contributor II
1,404 Views

I'd guess that 'Found' is part of an error message that the script has failed to detect as such, and has then substituted without quoting...

Altera_Forum
Honored Contributor II
1,404 Views

So, if this is a message that states it has failed to find a file, any ideas what is the name of the file it has failed to find? 

 

or is there a log somewhere to check?
Altera_Forum
Honored Contributor II
1,404 Views

You need to determine what is calling nios2-elf-objcopy.exe ... I don't know anything about the Altera build scheme. 

 

You are a bit hamstrung by not being on lunix (or other unix-like os) where you could replace the objcopy with (say) a script that echoes it arguments - they might be illuminative as well.
Altera_Forum
Honored Contributor II
1,404 Views

I have a linux system meant for uclinux development but I set aside due to probloems with the altera blaster. 

 

I think altera really needs to get the installer for linux sorted out. 

 

Just checked, its only on this particular project. Will try to recreate the entire project and see what happens.
Altera_Forum
Honored Contributor II
1,404 Views

I just had the exact same problem with EDS in Quartus 13.1, but I also found out what was causing the problem.  

 

I had just created another workspace, because I had two parallell development projects. So what I did was to remove both workspaces (i.e. removed the .metafile directory). Restarted Eclipse and choosed one of the directories and then I imported the project to the workspace and everything work as normal again. 

 

/BR Johan Karlsson
Altera_Forum
Honored Contributor II
1,404 Views

This works! Thank you very much Johan! Indeed erasing the workspace is the solution. (I completely erased the folder keeping only one file which contained my test code)

MTala1
Beginner
1,404 Views

face same problem with Quartus 18, solved based on Karlsson advise. thanks

Reply