Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
803 Views

make menuconfig fails with 20120802-tarball

Hello, 

 

after I got the DE0-nano up and running the last days with the linux-tarball from 2009 

I want to switch to the actual branch and my custom board. 

 

For this I downloaded and "installed" the 20120802-linux-tarball as described in 

alterawiki.com/wiki/Install_Nios_II_Linux 

I also installed the precompiled nios2gcc-20080203.tar.bz2 toolchain. 

I run the './update' too. 

 

Then I was going to 'make menuconfig' but it stops with the following message: 

guinea@guinea-VirtualBox:~/Dev/uClinux/nios2-linux/uClinux-dist$ make menuconfig find vendors -mindepth 2 '(' -name .svn -prune ')' -o -type f -name Kconfig -print | sed 's:^:source ../:' > vendors/Kconfig config/mkconfig > Kconfig KCONFIG_NOTIMESTAMP=1 /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf Kconfig /bin/sh: /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf: cannot execute the file make: *** Error 126 guinea@guinea-VirtualBox:~/Dev/uClinux/nios2-linux/uClinux-dist$  

 

the "mconf" attributes are: 

-rwxr-xr-x 1 guinea guinea 153127 2011-11-21 20:24 /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf 

 

My system is: ubunut 10.10 and gcc 4.2.4 (Ubuntu 4.2.4-1ubuntu3) and GNU Make 3.81 

 

Has anyone a hint how to solve this problem? 

 

Thx in advance 

guinea
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
68 Views

Presumably it also fails to run if you try to execute it directly? 

Some programs that might give informative output: 

- file mconf 

- ldd mconf 

- objdump -p mconf
Altera_Forum
Honored Contributor I
68 Views

Hi dsl, 

 

thank you very much for your helpfully direction. 

You are right, 'mconf' can't be executed directly. 

 

Here's my output of the file analysis: 

guinea@guinea-VirtualBox:~/Dev/uClinux/nios2-linux/uClinux-dist$ file /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, not stripped guinea@guinea-VirtualBox:~/Dev/uClinux/nios2-linux/uClinux-dist$ ldd /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf not a dynamic executable guinea@guinea-VirtualBox:~/Dev/uClinux/nios2-linux/uClinux-dist$ objdump -p /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf /home/guinea/Dev/uClinux/nios2-linux/uClinux-dist/config/kconfig/mconf: file format elf64-x86-64 Program Header: PHDR off 0x0000000000000040 vaddr 0x0000000000400040 paddr 0x0000000000400040 align 2**3 filesz 0x00000000000001c0 memsz 0x00000000000001c0 flags r-x INTERP off 0x0000000000000200 vaddr 0x0000000000400200 paddr 0x0000000000400200 align 2**0 filesz 0x000000000000001c memsz 0x000000000000001c flags r-- LOAD off 0x0000000000000000 vaddr 0x0000000000400000 paddr 0x0000000000400000 align 2**21 filesz 0x000000000001e2cc memsz 0x000000000001e2cc flags r-x LOAD off 0x000000000001e2d0 vaddr 0x000000000061e2d0 paddr 0x000000000061e2d0 align 2**21 filesz 0x0000000000001cf0 memsz 0x0000000000005198 flags rw- DYNAMIC off 0x000000000001e2f8 vaddr 0x000000000061e2f8 paddr 0x000000000061e2f8 align 2**3 filesz 0x00000000000001b0 memsz 0x00000000000001b0 flags rw- NOTE off 0x000000000000021c vaddr 0x000000000040021c paddr 0x000000000040021c align 2**2 filesz 0x0000000000000044 memsz 0x0000000000000044 flags r-- EH_FRAME off 0x000000000001b9dc vaddr 0x000000000041b9dc paddr 0x000000000041b9dc align 2**2 filesz 0x0000000000000804 memsz 0x0000000000000804 flags r-- STACK off 0x0000000000000000 vaddr 0x0000000000000000 paddr 0x0000000000000000 align 2**3 filesz 0x0000000000000000 memsz 0x0000000000000000 flags rw- Dynamic Section: NEEDED libncursesw.so.5 NEEDED libtinfo.so.5 NEEDED libc.so.6 INIT 0x0000000000401b78 FINI 0x0000000000415ef8 GNU_HASH 0x0000000000400260 STRTAB 0x0000000000400d10 SYMTAB 0x00000000004002c0 STRSZ 0x0000000000000391 SYMENT 0x0000000000000018 DEBUG 0x0000000000000000 PLTGOT 0x000000000061e4b8 PLTRELSZ 0x00000000000008e8 PLTREL 0x0000000000000007 JMPREL 0x0000000000401290 RELA 0x00000000004011d0 RELASZ 0x00000000000000c0 RELAENT 0x0000000000000018 VERNEED 0x0000000000401180 VERNEEDNUM 0x0000000000000001 VERSYM 0x00000000004010a2 Version References: required from libc.so.6: 0x0d696913 0x00 05 GLIBC_2.3 0x09691974 0x00 04 GLIBC_2.3.4 0x06969194 0x00 03 GLIBC_2.14 0x09691a75 0x00 02 GLIBC_2.2.5 guinea@guinea-VirtualBox:~/Dev/uClinux/nios2-linux/uClinux-dist$  

 

After recompiling the 'mconf' with my 32-bit ubuntu I can successfully execute 'make menuconfig' :) 

 

Let's see what surprises will next upcome ... 

 

Greetings 

guinea 

 

@Altera P.S.: Perhaps it is a good idea to update the instructions at "alterawiki.com/wiki/Install_Nios_II_Linux"
Altera_Forum
Honored Contributor I
68 Views

Hi all,  

Very helpful thread. I, however, got stuck with the part when it was said "compile 'mconf' with my 32-bit ubuntu". I found that by just removing the compiled file "mconf" and then running "make menuconfig" as usual worked as well - the file gets generated through the "make menuconfig" process so no need to try and cross-compile manually. This could be obvious to you guys but it might help other beginners like myself. 

 

Thanks for the support.
Altera_Forum
Honored Contributor I
68 Views

Unluckily , i encountered the same problem.But, 

Luckily, i encountered you ;Your ideals seems to be very helpful ,but i want to know :how did you recompile your mconf ? 

thanks  

 

Tommei
Reply