Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
748 Views

mount SD card problem

Hi  

 

I want to mount SD card to /mnt 

 

I follow the altera wiki http://www.alterawiki.com/wiki/mmcsd 

 

But I can't mount successfully 

 

When I boot kernel the information is  

 

********************************************** 

uClinux/Nios II 

Altera Nios II support (C) 2004 Microtronix Datacom Ltd. 

Built 1 zonelists. Total pages: 2032 

Kernel command line: 

PID hash table entries: 32 (order: 5, 128 bytes) 

spi_read read data time out 

spi_read read data time out 

spi_read read data time out 

spi_read read data time out 

spi_read read data time out 

Dentry cache hash table entries: 1024 (order: 0, 4096 bytes) 

Inode-cache hash table entries: 1024 (order: 0, 4096 bytes) 

Memory available: 5692k/8192k RAM, 0k/0k ROM (1695k kernel code, 715k data) 

Mount-cache hash table entries: 512 

NET: Registered protocol family 16 

NET: Registered protocol family 2 

IP route cache hash table entries: 1024 (order: 0, 4096 bytes) 

TCP established hash table entries: 1024 (order: 0, 4096 bytes) 

TCP bind hash table entries: 1024 (order: 0, 4096 bytes) 

TCP: Hash tables configured (established 1024 bind 1024) 

TCP reno registered 

SPI: Nios SPI bus device version 0.1 

io scheduler noop registered 

io scheduler deadline registered (default) 

Serial: JTAG UART driver $Revision: 1.3 $ 

ttyJ0 at MMIO 0x838010b0 (irq = 0) is a jtag_uart 

YOU have init Device 254 

JELLO EXMAPLE INIT 

TCP cubic registered 

NET: Registered protocol family 1 

NET: Registered protocol family 17 

Freeing unused kernel memory: 588k freed (0x29b8000 - 0x2a4a000) 

Shell invoked to run file: /etc/rc 

Command: hostname uClinux 

Command: mount -t proc proc /proc 

Command: mount -t sysfs sysfs /sys 

Command: mount -t usbfs none /proc/bus/usb 

mount: Mounting none on /proc/bus/usb failed: No such file or directory 

Command: mkdir /var/tmp 

Command: mkdir /var/log 

Command: mkdir /var/run 

Command: mkdir /var/lock 

Command: mkdir /var/empty 

Command: ifconfig lo 127.0.0.1 

Command: route add -net 127.0.0.0 netmask 255.0.0.0 lo 

Command: cat /etc/motd 

*************************************************** 

 

And I can't find the mmcblk0 at /dev 

 

How counld I solve it?? 

 

Please help me 

Thank you very much
0 Kudos
0 Replies
Reply