Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,450 Views

my first fpga hps

Hello, 

 

Im just trying to run my_first_hps_fpga but when I try to make in the shell there is an error  

I dont get where is the problem  

pleaase help me 

 

there is an attachement.
0 Kudos
5 Replies
Altera_Forum
Honored Contributor I
121 Views

Sorry the forum automatically reduced your image and the error message is unreadable. Please either paste the text in the forum or use another format than jpeg.

Altera_Forum
Honored Contributor I
121 Views

yes , when I launch make  

arm-linux-gnueabihf-gcc-static-g-wall -I/ip/altera/hps/altera_hps/hwlib/include -c main.c -o-main.o 

process began :create Process<NULL, arm-linux-gnueabihf-gcc-static-g-wall -I/ip/altera/hps/altera_hps/hwlib/include -c main.c -o-main.o ---> failed  

the error was : make <e=2> the system cannot find the file specified . 

 

Itry to run the project in DEmonstrations SOC-fpga-my first _hps_fpga flowing the same steps like this project :https://www.youtube.com/watch?v=2wuket4-q7q 

thank u
Altera_Forum
Honored Contributor I
121 Views

The name of the comiler command is arm-linux-gnueabihf-gcc, so I wonder if you are missing some spaces in your makefile. Do you really have arm-linux-gnueabihf-gcc-static-g-wall without any spaces? -static and "-g -Wall" (with a capital W) are also options that should be separated with spaces. 

Could you show your makefile?
Altera_Forum
Honored Contributor I
121 Views

yeaah Im just put the commnd make and it automatically generated 

 

MY operating system is windows 8.1 

Should I have linux to do this in my laptop ? 

MY MAKE FILE 

#  

TARGET = my_first_hps-fpga 

 

#  

CROSS_COMPILE = arm-linux-gnueabihf- 

CFLAGS = -static -g -Wall -I${SOCEDS_DEST_ROOT}/ip/altera/hps/altera_hps/hwlib/include 

LDFLAGS = -g -Wall  

CC = $(CROSS_COMPILE)gcc 

ARCH= arm 

 

 

build: $(TARGET) 

$(TARGET): main.o  

$(CC) $(LDFLAGS) $^ -o $@  

%.o : %.c 

$(CC) $(CFLAGS) -c $< -o $@ 

 

.PHONY: clean 

clean: 

rm -f $(TARGET) *.a *.o *~
Altera_Forum
Honored Contributor I
121 Views

No you don't need linux, as long as you are using the SOC EDS shell it should work fine. Could you check out if SOCEDS_DEST_ROOT is set correctly in the shell? just write: 

echo $SOCEDS_DEST_ROOT
Reply