Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

nios ii error, [FAT]the partition type(12) is not supported.

Altera_Forum
Honored Contributor II
1,033 Views

Hi all, 

 

I have an Altera Cyclone V gx starter kit board, and I wanted to test some of the demonstrations provided. One of them, C5G_SD_DEMO, is supposed to provide an example of how a micro-sd card is read. 

 

I have a 2gb micro-sd card, that says it is a FAT32 File System when I connect it with my PC. However, when I try to run the .bat demo, I get the following error:  

 

[FAT]the partition type(12) is not supported. 

[FAT]Fat_Mount fail 

Failed to mount the SDCARD! 

Please insert the SDCARD into C5G board and press KEY3. 

 

This partition type comes up from one of the .c files included in the example, with the following code snippet: 

 

// check file system  

FirstPartitionEntry = 0x1BE; 

//PartitionType = szBlock[FirstPartitionEntry + 4]; 

PartitionType = szBlock[0x01C2]; 

if (PartitionType == PARTITION_FAT16){ 

FAT_DEBUG(("FAT16\n")); 

}else if (PartitionType == PARTITION_FAT32){ 

FAT_DEBUG(("FAT32\n")); 

}else{  

FAT_DEBUG(("the partition type(%d) is not supported.\n", PartitionType)); 

return FALSE; // only support FAT16 in this example 

}  

 

So, does anyone know what I can do? Keep in mind, with my previous DE0 board, reading a regular (not micro) sd card, that was FAT16 format, I was able to do that succesfully using University Program IP cores. So, I am somewhat confused as to why this demo is not working with a micro-sd card.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
248 Views

Anyone knows a solution to this? I have formatted a 16GB micro SD card to create a a sole 500MB FAT16 partition (ignoring remaining space). I am using a micro SD adapter to put it into the DE2 115 board. However, I get the "Failed to mount the SDCARD!" message. Pressing Key 3 just prints the same message again. 

 

What is the workaround for this?
LVo001
Beginner
248 Views

I know this has been a year ago, but has anyone found a solution to this? I'm having the exact same problem. Seems like a lot of questions on this forum go unanswered.

Reply