Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

nios2-bsp-create-settings failed error

Altera_Forum
Honored Contributor II
1,569 Views

Hi everyone, I am getting this error when I am trying 

 

new-> Nios II Application and BSP from Template 

 

Compilation is successful in Quartus. But I can not create a Project in eclipse. 

 

I am using the version 13.0sp1. 

 

Thanks for the answers. 

 

INFO: Finished initializing SOPC project local software IP. Total time taken = 4 seconds 

INFO: Searching for BSP components with category: driver_element 

INFO: Searching for BSP components with category: software_package_element 

INFO: Loading drivers from ensemble report.  

INFO: Finished loading drivers from ensemble report. 

SEVERE: Setting does not exist for BSP: "hal.stdın". 

WARNING: Tcl script "bsp-set-defaults.tcl " error: Setting does not exist for BSP: "hal.stdın". 

SEVERE: Setting does not exist for BSP: "hal.max_file_descriptors". 

SEVERE: Setting does not exist for BSP: "hal.max_file_descriptors". 

SEVERE: nios2-bsp-create-settings failed. 

nios2-bsp: nios2-bsp-create-settings failed 

nios2-bsp hal . C:/altera/13.0sp1/proj_Helloworld/proj_qsys.sopcinfo --set hal.max_file_descriptors 4 --set hal.enable_small_c_library true --set hal.sys_clk_timer none --set hal.timestamp_timer none --set hal.enable_exit false --set hal.enable_c_plus_plus false --set hal.enable_lightweight_device_driver_api true --set hal.enable_clean_exit false --set hal.enable_sim_optimize false --set hal.enable_reduced_device_drivers true --set hal.make.bsp_cflags_optimization '-Os' --cpu-name nios2_qsys_0 failed
0 Kudos
0 Replies
Reply