Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

nios2-terminal doesn't work properly on ubuntu 13.10

Altera_Forum
Honored Contributor II
876 Views

Hi, 

 

I've just recently installed Quartus II 13.0sp1 on my 64 bit ubuntu 13.10 running laptop. After installing libraries needed to run qsys and eclipse, I've managed to download hello world on nios2. The problem is nothing is printed back to console. And when I run nios2-terminal from console, it starts and after a few seconds it exits with following message: 

 

nios2-terminal: connected to hardware target using JTAG UART on cable 

nios2-terminal: "USB-Blaster [3-3]", device 1, instance 0 

 

 

nios2-terminal: (Use the IDE stop button or Ctrl-C to terminate) 

 

 

 

 

 

 

nios2-terminal: exiting due to I/O error communicating with target 

 

Now I don't know what to do. I've tried several things I found while searching for the solution on the web, but nothing worked. Can anybody help me with this?
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
149 Views

try "sudo nios2-terminal"

Altera_Forum
Honored Contributor II
149 Views

 

--- Quote Start ---  

try "sudo nios2-terminal" 

--- Quote End ---  

 

 

It outputs 

 

./nios2-terminal-wrapped: error while loading shared libraries: libjtag_atlantic.so: cannot open shared object file: No such file or directory 

 

But that library is there in linux64 folder.
Reply