Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

no monitor terminal and usb blaster loses setting linux

Altera_Forum
Honored Contributor II
810 Views

Hi all, 

I am runing quartus 13.1 with qprogrammer 13.1 and the university monitor program, specifically the altera monitor program with the DE-0 nano board. I am using fedora 20 64 bit as OS and have installed the programs. I am having two problems, first with the usb blaster. I have setup the 51-usbblaster.rules according to the archlinux wiki (https://wiki.archlinux.org/index.php/altera_design_software) and it worked only a couple of times. After a few times (2 or 3) of connecting to the board it loses the configuration and I must repeat the instructions in that wiki, from copying the file and running jtagconfig. Sometimes I have to repeat those a couple times before it works again. I tried to use the Altera instructions for configuring the blaster for redhat v4+ and that did not work at all. I have this problem whether I use the qprogrammer or altera monitor program to connect to the board. The next problem I have is with the altera monitor program, when I actually get the blaster to work and download my code to the board, then click run I get and error saying that "bad interpreter no file found or does not exist" for the terminal of the monitor program. I have checked and file was not installed in the directory it is looking, but it installed in another location. The file and path it is looking in is .../University_Program/altera-monitor-program/bin/bin/nios2terminal, it is installed in .../altera-monitor-program/bin/nios2terminal . I have made that directory as the 2nd bin folder does not exist and copied that file to the new folder and still receive the same error. I did only copy the file so there were 2 instances of it, but it did not work. I need to have the terminal for I/O, I have compiled and run these programs on other machines (windows7 and mac) and they work. 

 

my 51-usbblaster .rules file looks like this and is in the /etc/udev/rules.d/ directory 

SUBSYSTEM=="usb", ATTR{idVendow}=="09fb", ATTR{idProduct}=="6001", MODE="0666" SUBSYSTEM=="usb", ATTR{idVendor}=="09fb", ATTR{idProduct}=="6002", MODE="0666" SUBSYSTEM=="usb", ATTR{idVendor}=="09fb", ATTR{idProduct}=="6003", MODE="0666" SUBSYSTEM=="usb", ATTR{idVendor}=="09fb", ATTR{idProduct}=="6010", MODE="0666" SUBSYSTEM=="usb", ATTR{idVendor}=="09fb", ATTR{idProduct}=="6810", MODE="0666"  

 

Appreciate any help 

dmcgu
0 Kudos
0 Replies
Reply