Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
769 Views

"Power On Reset" Issue

Hello Friends, 

 

I have successfully Write The Flash for simple Hello World Code and it work even after Pressing "CPU Reset" but it not work "Power ON" ,  

please help me out how do make this work on "power on"  

 

 

i am using "altera cyclone development kit" having cyclone device and using "altera/quartus//example/cyclone_1c20/standard" example. 

 

 

Regards 

 

kaushal
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
36 Views

 

--- Quote Start ---  

Hello Friends, 

 

I have successfully Write The Flash for simple Hello World Code and it work even after Pressing "CPU Reset" but it not work "Power ON" ,  

please help me out how do make this work on "power on"  

 

 

i am using "altera cyclone development kit" having cyclone device and using "altera/quartus//example/cyclone_1c20/standard" example. 

 

 

Regards 

 

kaushal 

--- Quote End ---  

 

 

detail of problem 

 

I have Altera Cyclone Development Kit (1C20 Board). 

and i am using your reference design (standard & Code is "Hello World"). 

 

using this board i am trying to learn how to program FLASH so that while "power on" it will display "hello world". 

 

The Task I have performed till now is  

1. Generate .sopc 

2. Compile standard nios2 design. (generate .sof) 

3. take a sample "hello world" from tamplets 

4. build it (generate .elf )and download to board using USB Blaster. 

 

#### It Display "Hello World" on Eclipse Terminal 

 

NEXT: Steps --Programming FLASH------------ 

1. Open the Flash Programmer from Eclipse 

2. Menu->File->New 

3. Add the .sopc file (From above point 1)  

4. Add .elf file 

5. Press Write to Flash Button. 

 

##### Open the Nios2 terminal# ### 

write following Command 

#nios2-download -r -g (as mentioned is data sheet) 

#nios2-terminal 

 

it start display "Hello World" 

 

if i press cpu reset it again display "hello world" 

--------------------------------------------------- 

problem 

--------------------------------------------------- 

if i power off the board and again power on the board it won't display "hello world" 

 

it mean my .sof and .elf is not in FLASH 

 

How Do i Permanently write .sof and .elf to my Board so the these two remain in Flash even i switch off the Board 

 

regards 

 

kaushal
Reply