Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

sshd does not work when shadow password is enabled

Altera_Forum
Honored Contributor II
847 Views

sshd does not work for me when shadow password is enabled. 

 

1. I can telnet to my box as root (with shadow password enabled) ==>> username/password is valid. 

2. If I disable shadow password, sshd works fine. I can login as root. ==>> the ssh keys are fine and sshd_config file is also good. 

 

Any ideas? 

 

I am using busybox login, shadow password. I have configured all internal APIs option in busybox. 

 

My box runs the 2010621 tar file. I updated the ssh and busybox directories to the latest without any change in behavior. Looks like I am missing something obvious. Including a snippet of the failure from '/bin/sshd -Dde'. 

 

I need to use shadow password for backward compatibility, so disabling shadow is not an option. 

 

ebug1: kex: client->server aes128-ctr hmac-md5 none 

debug1: kex: server->client aes128-ctr hmac-md5 none 

debug1: SSH2_MSG_KEX_DH_GEX_REQUEST received 

WARNING: /etc/config/moduli does not exist, using fixed modulus 

debug1: SSH2_MSG_KEX_DH_GEX_GROUP sent 

debug1: expecting SSH2_MSG_KEX_DH_GEX_INIT 

debug1: SSH2_MSG_KEX_DH_GEX_REPLY sent 

debug1: SSH2_MSG_NEWKEYS sent 

debug1: expecting SSH2_MSG_NEWKEYS 

debug1: SSH2_MSG_NEWKEYS received 

debug1: KEX done 

debug1: userauth-request for user root service ssh-connection method none 

debug1: attempt 0 failures 0 

Failed none for root from 169.254.1.11 port 58277 ssh2 

debug1: userauth-request for user root service ssh-connection method keyboard-interactive 

debug1: attempt 1 failures 0 

debug1: keyboard-interactive devs  

debug1: auth2_challenge: user=root devs= 

debug1: kbdint_alloc: devices '' 

debug1: userauth-request for user root service ssh-connection method password 

debug1: attempt 2 failures 1 

Failed password for root from 169.254.1.11 port 58277 ssh2
0 Kudos
0 Replies
Reply