Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12469 Discussions

trispeed ethernet nios2 eclipse new project and bsp build error

venkatasateesh
Beginner
446 Views

Hi Dear intel team,

sub: trispeed ethernet nios2 eclipse new project and bsp build error

 

i am using quarts prime lite version 20.1 running on windows 10 OS . while  building project to  generating elf file  tri speed ethernet in eclipse ,we are getting some errors as shown below.

 

wslpath: /mnt/c/nios2_practice/Trispeed_ethernet/ethernet_04_12_21/software/web_server_ENT0_bsp//obj/HAL/src/crt0.o: No such file or directory
touch web_server_ENT0.elf.srec
Info: Building /mnt/c/nios2_practice/Trispeed_ethernet/ethernet_04_12_21/software/web_server_ENT0_bsp/
make --no-print-directory -C /mnt/c/nios2_practice/Trispeed_ethernet/ethernet_04_12_21/software/web_server_ENT0_bsp/
Compiling alt_close.c...
nios2-elf-gcc.exe -xc -MP -MMD -c -I./drivers/inc -I./drivers/inc/iniche -I./iniche/inc -I./iniche/src/h -I./iniche/src/h/nios2 -I./iniche/src/nios2 -I./UCOSII/inc -I./HAL/inc -I. -I./drivers/inc -pipe -D__hal__ -DALT_NO_INSTRUCTION_EMULATION -DALTERA_TRIPLE_SPEED_MAC -DALT_INICHE -DRO_ZIPFS -D__ucosii__ -DALTERA_AUTONEG_TIMEOUT_THRESHOLD=2500 -DALTERA_CHECKLINK_TIMEOUT_THRESHOLD=10000 -DALTERA_NOMDIO_TIMEOUT_THRESHOLD=1000000 -DTSE_MY_SYSTEM -O0 -g -Wall -mno-hw-div -mhw-mul -mno-hw-mulx -mgpopt=global -o obj/HAL/src/alt_close.o HAL/src/alt_close.c
In file included from ./HAL/inc/includes.h:23,
from ./UCOSII/inc/priv/alt_sem_ucosii.h:45,
from ./UCOSII/inc/os/alt_sem.h:75,
from ./HAL/inc/priv/alt_file.h:44,
from HAL/src/alt_close.c:37:
./UCOSII/inc/ucos_ii.h:1708:2: error: #error "OS_CFG.H, Missing OS_TICKS_PER_SEC: Sets the number of ticks in one second"
1708 | #error "OS_CFG.H, Missing OS_TICKS_PER_SEC: Sets the number of ticks in one second"
| ^~~~~
make[1]: *** [Makefile:746: obj/HAL/src/alt_close.o] Error 1
make: *** [Makefile:846: /mnt/c/nios2_practice/Trispeed_ethernet/ethernet_04_12_21/software/web_server_ENT0_bsp/-recurs-make-lib] Error 2

10:49:35 Build Finished (took 9s.144ms)

                                          i am requesting anyone know  solution  for this .let me known  steps to resolve the above issue .i am attaching some of error image also

     i am looking forward for your response

Thanks &Regards

sateesh

           

0 Kudos
8 Replies
venkatasateesh
Beginner
423 Views

Hi Dear intel team,

 

i have tried already this solution https://www.intel.com/content/www/us/en/support/programmable/articles/000073953.html,but the error did not resolved .could you Suggest any other solution for the above issue .

 

 

 

 

 

Thanks&Regards

B.sateesh

 

venkatasateesh
Beginner
408 Views

Hi Dear Intel team,

 

 

the issue did not resolve ,i am looking for technical  assistance for above  issue ,do you have instant chatting  technical team to get support with out delay .

                                                I am looking forward for your response

 

 

 

Thanks&Regards

B.Sateesh

EricMunYew_C_Intel
Moderator
395 Views

It should be fixed in Quartus Lite 20.1.1. Have you tried it.


venkatasateesh
Beginner
391 Views

Hi intel technical team ,

 

      i have tried already , what ever suggestion  given above ,could you give any other solution for  above issue.in every IDE  versions several bugs coming .still your releasing  upgraded version without fixing issues.

 

 

 

 

Thanks&Regards

B.Venkata Sateesh

EricMunYew_C_Intel
Moderator
323 Views

You may refer to below and try to uninstall and reinstall the WSL.

https://www.intel.com/content/www/us/en/support/programmable/articles/000074066.html


venkatasateesh
Beginner
300 Views

Hi intel team,

  i have  resolved the issue. very much early before coming your post.you can close issue

 

 

 

 

 

 

 

 

 

EricMunYew_C_Intel
Moderator
286 Views

Since this thread had been answered, we shall close this thread. If you still need further assistance, you are welcome to post a response within 15days or open a new thread, some one will be right with you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions.


Reply