Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
717 Views

tse_mac Initialize BUT not respond to PING

I have initialize my ESDK Cyclone-III board (see attached print-screen) but it won't respond to PING. it already acquire Static IP address. 

 

But it won't respond to ping request 

 

in SOPC tse_mac clock is ddr2_bot_auxhalf = 82.5 Mhz , i have also change the clock from ddr2_bot_auxhalf to ddr2_bot_auxfull = 165 mhz but still not responding the PING request. 

 

Regards 

Kaushal
0 Kudos
3 Replies
Highlighted
Valued Contributor III
2 Views

Still waiting for any clue....

0 Kudos
Highlighted
Valued Contributor III
2 Views

Have you checked to make sure# ifdef PING_APP is set to true? Ping is an optional task in the InterNiche stack, so it's not necessarily guaranteed to be set to run automatically. Looking at your program's output it doesn't seem to be running. If it were, you should see something like: Created "PING client" task (Prio: 11)

0 Kudos
Highlighted
Valued Contributor III
2 Views

 

--- Quote Start ---  

Have you checked to make sure# ifdef PING_APP is set to true? Ping is an optional task in the InterNiche stack, so it's not necessarily guaranteed to be set to run automatically. Looking at your program's output it doesn't seem to be running. If it were, you should see something like: Created "PING client" task (Prio: 11) 

--- Quote End ---  

 

Thanx for your post. 

If i Reduce the VIC frequency from ddr2_bot_auxfull to ddr2_bot_auxhalf it start responding to PING but at the same time my VIC stop receiving interrupt, so i need both VIC and InterNiche work together (desirable for my application)
0 Kudos