Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
770 Views

uClinux on Stratix III board

Hello everyone, 

I'm new on uClinux. 

 

I have a Stratix III dev board and I want to use uClinux in it in order to use some common periferials like ethernet and communicate with custom logic components designed in VHDL (these components are not ready yet).  

 

I used the hardware design provided in the post (forum did not allowed me to post links) 

24534# 2 

to implement NIOS in the Stratix III FPGA Development Kit.  

 

I was able to run the examples provided in the Nios 2 IDE (web server and server socket), meaning that the softcore was functional. 

 

Then I tried to Install uClinux on the Stratix III dev board, using the same hardware design. 

I tried to follow the steps described in: AlteraWiki / Build uCLinux with MMU 

but I had no success. 

 

I generated my hardware description using: 

sopc-create-header-files --single my_nios2_fpga.h 

in the project directory. 

I'm getting a error message when I try to compile it. 

 

Well, I think I'm using the wrong approach. 

 

Can someone give me some guidance on how to compile and install uCLinux in the stratix III dev board?? 

 

I want a system with no mmu. 

What are the correct buildtools to use in this case? 

 

Thanks  

Raphael Philipe Mendes da Silva
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
33 Views

Please post the error messages you are getting.

Altera_Forum
Honored Contributor I
33 Views

Let's simplify the question. 

If I wanted to use linux (no matter whether it is uClinux or Nios Linux) in my "Stratix III DSP development kit", what would be the steps in order to get it functional? 

 

It has to have Altera Triple Speed Ethernet driver support. 

 

Can someone explain to me what steps should I take in order to do this? 

 

Thank you.
Altera_Forum
Honored Contributor I
33 Views

http://alterawiki.com/wiki/linux_for_the_nios_ii_processor 

 

Download the distribution following these steps: 

http://alterawiki.com/wiki/downloading_linux_distribution 

 

The latest unstable-nios2mmu branch has some Device-Tree stuff that's kind of in flux and does not support the TSE yet, so I recommend starting with the v2.6.37-nios2 tag: 

cd linux2.6 git branch unstable-nios2mmu origin/unstable-nios2mmu git checkout -f unstable-nios2mmu git branch my_nios2mmu v2.6.37-nios2 git checkout -f my_nios2mmu  

Also make sure uClinux-dist is on the "trunk" branch. 

 

Create a design and add it to Linux following these steps: 

http://alterawiki.com/wiki/creating_a_nios_ii_design_with_an_mmu