Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12384 Discussions

uart instead of the jtag_uart_0

Gerhard56
New Contributor I
213 Views

Hi,

I have a sample, which uses a uart.

So I didn't add a jtag_uart_0 and now I get errors when generating the BSP. Any idea how to redirect a jtag-uart-0 to a uart?

 

With best regards

 

Gerhard

0 Kudos
3 Replies
BoonBengT_Intel
Moderator
152 Views

Hi @Gerhard56,

Thank you for posting in Intel community forum, hope this message find you well and apologies for the delayed in response.
I if understand correctly the situation, perhaps the following steps should help to change the jtag-uart-0 to a uart 1) right click on nios ii project, click Index --> Rebuild 2) With that in the BSP editor updated uart should be should be showing up, and click on the Generate to ensure updated.
Please do try out and let us know if it helps.


Best Wishes
BB

 

Gerhard56
New Contributor I
145 Views

Hi BB,

 

I found out how to switch between the UARTs, so this case can be closed.

 

With best regards and stay healthy

 

Gerhard

BoonBengT_Intel
Moderator
128 Views


Hi @Gerhard56,

Noted on your feedback and good to know that it is working now, we would be closing the thread.

Best Wishes
BB

Reply