Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
814 Views

uboot problem about "bootm" command

Please please please help me. 

 

I am almost crazy. 

 

The following is the problem description. 

 

Now, I have a DE0 board, uClinux kernel, NIOSII processor, and u-boot. 

 

The version of uClinux kernel is uClinux-dist-20110603. 

 

The NIOS II version is 10.1 and quartus II version is 10.1. 

 

The u-boot version is u-boot-2011.06. 

 

I want to download the .sof file to DE0 board and then boot kernel. 

 

 

I have the three way to achieve the goal. I fail in one of them which is used the "bootm" command. 

 

First, I don't use the u-boot to boot kernel. (OK:)) 

Directly download the kernel to the memory and then boot kernel. 

(I use the compressed image kernel which is not .gz file but through "misc.c" ) 

 

--- Quote Start ---  

 

[NIOS2_EDS] nios2-download -g zImage 

[NIOS2_EDS] nios2-terminal 

 

--- Quote End ---  

 

 

Second, I use the u-boot's "go"command to boot kernel. (OK:)) 

Directly download the kernel to flash by using "flash programmer tool" of NIOS IDE. And then I copy the image kernel from flash through "cp.b" command. Finally, I key in "go" command booting kernel.(I use the uncompressed image kernel which is not through "misc.c") 

 

 

--- Quote Start ---  

 

==>cp.b 02400000 01800000 400000 

==>go 01800000 

 

--- Quote End ---  

 

 

 

Third, I use the u-boot's "bootm" command to boot kernel. (FAIL:cry::) 

(I use the compressed image kernel which is not .gz file but through "misc.c") 

 

1. I create the uImage through the "mkimage" tool. 

 

The following is the settings 

 

 

--- Quote Start ---  

 

mkimage -n 'linux- 2.6' -A nios2 -O linux -T kernel -C none -a 0x01800000 -e 0x01800040 -d zImage uImage_18 

 

--- Quote End ---  

 

 

 

--- Quote Start ---  

 

mkimage -n 'linux- 2.6' -A nios2 -O linux -T kernel -C none -a 0x01800000 -e 0x01800000 -d zImage uImage_1D 

 

--- Quote End ---  

 

 

The following is board information 

 

--- Quote Start ---  

 

==> bdinfo 

mem start = 0x01800000 

mem size = 0x00800000 

flash start = 0x82400000 

flash size = 0x00400000 

flash offset= 0x00000019 

ethaddr = (not set) 

ip_addr = 0.0.0.0 

baudrate = 1 bps 

 

--- Quote End ---  

 

 

 

2. bootm command 

 

A. copy uImage_18 

 

--- Quote Start ---  

 

==>cp.b 02400000 01800000 200000 

==>bootm 01800000 - 

 

# # Booting kernel from Legacy Image at 01800000 ... 

Image Name: linux- 2.6 

Image Type: NIOS II Linux Kernel Image (uncompressed) 

Data Size: 1457595 Bytes = 1.4 MiB 

Load Address: 01800000 

Entry Point: 01800040 

Verifying Checksum ... OK 

XIP Kernel Image ... 

OK <-----------------------------(stuck here.......) 

 

 

--- Quote End ---  

 

 

 

B. copy uImage_1D 

 

--- Quote Start ---  

 

==>cp.b 02400000 01D00000 200000 

==>bootm 01D00000 - 

 

# # Booting kernel from Legacy Image at 01D00000 ... 

Image Name: linux- 2.6 

Image Type: NIOS II Linux Kernel Image (uncompressed) 

Data Size: 1457595 Bytes = 1.4 MiB 

Load Address: 01800000 

Entry Point: 01800000 

Verifying Checksum ... OK 

Loading Kernel Image ... 

OK <-----------------------------(stuck here.......) 

 

--- Quote End ---  

 

 

Could you give me "any any any" suggestions. I need them. 

Please please help me. 

God bless you. 

Thank you very much.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
54 Views

Please do not post your question multiple times.... just choose a forum and put it there

Altera_Forum
Honored Contributor I
54 Views

 

--- Quote Start ---  

Please do not post your question multiple times.... just choose a forum and put it there 

--- Quote End ---  

 

 

Sorry, I would not do that. 

 

Excuse me,could you give me some suggestion about this problem. 

Thank you very much.
Reply