Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12366 Discussions

unrecognized command line options in NIOS-II example project

icstars
Beginner
403 Views

Hello!
I'm getting started with NIOS-II 
I've succesfully built hardware design and created bsp from it
When I am trying to build example "hello World" project i am getting errors like:


arm-none-eabi-gcc.exe: error: unrecognized command line option '-mno-hw-div'
arm-none-eabi-gcc.exe: error: unrecognized command line option '-mno-hw-mul'
arm-none-eabi-gcc.exe: error: unrecognized command line option '-mno-hw-mulx'
arm-none-eabi-gcc.exe: error: unrecognized command line option '-mgpopt=global'
make: *** [obj/default/hello_world.o] Error 1

I haven't touched any build settings or bsp options, my qsys project also has the most default settings possible
I am using Quartus Prime Lite 18.1 
Couls you please tell me what I am doing wrong?

0 Kudos
4 Replies
BoonBengT_Intel
Moderator
367 Views

Hi @icstars,

Thank you for posting in Intel community forum, hope this message find you well and apologies for the delayed in response.
Did some investigation and it seem that the culprith might be the wslpath program environment on your machine have changed.
Is there any OS updates on your machine recently?

Would suggest to try on the following workaround, Open the project Makefile, and look for the following link of code:
APP_LDFLAGS += -msys-lib=$(call adjust-path-mixed,$(SYS_LIB))
(by default it is around line 326 if there is no changes on the files)

Change to the following :
APP_LDFLAGS += -msys-lib=hal_bsp
And try to rebuild your project to see if it works.
Please do let us know if that helps.

Warm regards.
BB

BoonBengT_Intel
Moderator
357 Views

Hi @icstars,

Greetings, by any chances did you managed to look into the clarification above or even try out the workaround stated.

Please do let us know if there is any difficulties doing so.

Warm regards

BB

BoonBengT_Intel
Moderator
330 Views

Hi @icstars,

Hope this message find you well and good day, unfortunately as we do not receive any response from you to the previous clarification that we have provided. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 
 
Warm Regards
BB

icstars
Beginner
312 Views

Hello BB!
Changing makefile didn't help me, but my projects started to work after removing and reinstalling arm  toolchain 
No idea how it works, but it solved the problem 
Thank you for your help!

Reply