Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
981 Views

wahen i flash my zimage on flash memory , i can't use telnet

hi all  

please , i use µclunix , when i flash the zimage in flash memory ans i desactive the JTAG UART , i can't use telnet , in my file RC , i add inetd&  

 

--- Quote Start ---  

 

hostname uClinux 

mount -t proc proc /proc -o noexec,nosuid,nodev 

mount -t sysfs sysfs /sys -o noexec,nosuid,nodev 

mount -t devpts devpts /dev/pts -o noexec,nosuid 

mount -t usbfs none /proc/bus/usb 

mkdir /var/tmp 

mkdir /var/log 

mkdir /var/run 

mkdir /var/lock 

mkdir /var/empty 

ifconfig lo 127.0.0.1 

route add -net 127.0.0.0 netmask 255.0.0.0 lo# dhcpcd -p -a eth0 & 

cat /etc/motd 

mknoddev 

ifconfig eth0 192.168.10.180 

inetd& 

 

--- Quote End ---  

 

but when i flash my Zimage in RAM , i can use telnet withou any problem 

please, if someone have an idea , or if there is other configuartion to be able to use the telnet , I realy need it  

thank's
0 Kudos
4 Replies
Highlighted
Valued Contributor III
11 Views

What if you 

disable the JTAG UART and run from RAM? 

enable the JTAG UART and run from flash?
0 Kudos
Highlighted
Valued Contributor III
11 Views

I have the same problem, 

I write sof in EPCS and program in CFI 

 

--- Quote Start ---  

 

sof2flash --epcs --input=<chemin>/irp.sof --output=fpga_sof.flash 

elf2flash --base=0x02800000 --end=0x02FFFFFF --reset=0x02800000 --input=zImage --output=uc_flash.flash --boot=<chemin>/Altera/nios2eds/components/altera_nios2/boot_loader_cfi.srec 

 

 

nios2-flash-programmer --epcs --base=0x03001800 fpga_sof.flash 

nios2-flash-programmer --base=0x02800000 uc_flash.flash 

 

--- Quote End ---  

uc_flash.flash = 6MBytes, so i changed Processor type and features--> Link address offset for booting from 0x00500000 to 0x01555555 (2/3 of my 32M sdram) 

 

I also changed rc file  

 

--- Quote Start ---  

 

hostname uClinux 

mount -t proc proc /proc -o noexec,nosuid,nodev 

mount -t sysfs sysfs /sys -o noexec,nosuid,nodev 

mount -t devpts devpts /dev/pts -o noexec,nosuid 

mount -t usbfs none /proc/bus/usb 

mkdir /var/tmp 

mkdir /var/log 

mkdir /var/run 

mkdir /var/lock 

mkdir /var/empty 

ifconfig lo 127.0.0.1 

route add -net 127.0.0.0 netmask 255.0.0.0 lo# dhcpcd -p -a eth0 & 

cat /etc/motd 

mknoddev 

ifconfig eth0 192.168.10.170 

inetd&  

 

--- Quote End ---  

 

After reboot, ping 192.168.10.170 work but not telnet 

(I disabled the JTAG UART and i have 2 uart in sopc used for my application) 

 

Thanks for help
0 Kudos
Highlighted
Valued Contributor III
11 Views

if you disable "Support for console on Altera JTAG UART" only it dosen't work  

but if you add Bypass output when no connection it work for me :)
0 Kudos
Highlighted
Valued Contributor III
11 Views

yessss it work thanks hayder and ykozlov (http://www.alteraforum.com/forum/member.php?u=26158)

0 Kudos