Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jmart198
Beginner
722 Views

why Nios eclipse force close after startup icon

Hi,

just installed Quartus 18.0 on Ubuntu 18.04 and when tried to open the eclipse this force close after startup image and in command line I get the error:

/home/julian/intelFPGA_lite/18.0/quartus/linux64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/x86_64-linux-gnu/libproxy.so.1)

Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgiolibproxy.so

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

/home/julian/intelFPGA_lite/18.0/quartus/linux64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/x86_64-linux-gnu/libproxy.so.1)

Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgiolibproxy.so

 

(Eclipse:26519): Gtk-WARNING **: 19:34:09.517: Could not load a pixbuf from icon theme.

This may indicate that pixbuf loaders or the mime database could not be found.

**

Gtk:ERROR:../../../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons/Humanity/status/16/image-missing.svg: Unable to load image-loading module: /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /home/julian/intelFPGA_lite/18.0/quartus/linux64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib/x86_64-linux-gnu/libicuuc.so.60) (gdk-pixbuf-error-quark, 5)

 

Any ideas?

 

Thanks.

0 Kudos
8 Replies
GHelb
Novice
465 Views

It seems that Quartus - at least the NIOS software part - no longer works in ubuntu.

 

I haven't been able to flag anyone down about this issue.

 

Best of luck!

Ahmed_H_Intel1
Employee
465 Views

Hi Gary,

The NIOS II SBT is working fine on Ubuntu. It seems you missed to update the installation files after getting it installed.

Please let me know if you need guidance on how to install Quartus on Ubuntu.

Regards,

 

GHelb
Novice
465 Views

I am not the original poster.

 

We are both talking about Quartus 18. The eclipse installation files you mention are for Quartus 19.

 

He's getting farther with ubuntu 18 than I am with ubuntu 16. Still broken though - for both of us it's dying before eclipse is invoked.

 

What, if any, additional files need to get added after installing Quartus 18? I don't find them mentioned?

Ahmed_H_Intel1
Employee
465 Views

Hi,

Are you facing certain errors, or it just dies without generating any error message?

Please this is very important to investigate the issue.

Regards,

 

jmart198
Beginner
465 Views

Hi AhmedH,

when launching the Nios from Quartus I can't see any errors, I can see the NIOS eclipse start image for just a frame and close without any message and indication. The error I put in this post is when launch the Nios from command line I tried to see If I could solve it.

 

Thanks,

regards,

Julian.

Ahmed_H_Intel1
Employee
465 Views

Can you please check the JAVA version you are using? is it up to date and installed properly?

 

jmart198
Beginner
465 Views

Hi, sorry for late answer @AhmedH_Intel​ . I've checked the java version, is the:

openjdk version "11.0.6" 2020-01-14

 

what version should I install?.I don't find any info about in the software prerequisites.

 

thanks,

regards.

 

JKast1
Beginner
276 Views

I experienced similar issue and when I run command

export SWT_GTK3=0

 

before running 

eclipse-nios2

the tool worked.

Reply