Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
249 Views

window10 Quartus pro 19.2 软件nio2 command shell 无法启动?

我下载的文件:eclipse-cpp-2019-06-R-win32-x86_64

我的安装指令:

  1. Extract the downloaded file into this directory: < Intel® Quartus® Prime installation directory>/nios2eds/bin. You should see the < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse folder after extraction is done.
  2. Rename the < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse folder to < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse_nios2.
  3. Extract < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse_nios2_plugins.zip for Windows or < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse_nios2_plugins.tar.gz for Linux* to < Intel® Quartus® Prime installation directory>/nios2eds/bin. The extraction overrides files in < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse_nios2.
  4. Verify the extraction is done correctly by making sure you see the < Intel® Quartus® Prime installation directory>/nios2eds/bin/eclipse_nios2/plugin_customization.ini file.
  5. You can now launch Nios® II SBT for Eclipse using eclipse-nios2.exe.

确定上面5步没有问题​

结果:

1582165853(1).png

1582165791(1).png

0 Kudos
10 Replies
Highlighted
Employee
40 Views

Hi,

 

Its seems the error is same as thsi forum:

https://forums.intel.com/s/question/0D50P00004NtxB8SAJ/quartus-prime-pro-192-nios-ii-command-shell-a...

I had with ticket: 1507321697 as mentioned in this forum, the developer is still investigating this problem.

Could you try to install "Quartus from the installation 19.2 and the Nios II SBT from the installation 18.1"?

 

Thanks

0 Kudos
Highlighted
Partner
40 Views

请问这个问题如何解决?

0 Kudos
Highlighted
Partner
40 Views

请问这个问题如何解决?

0 Kudos
Highlighted
Employee
40 Views

Hi,

 

This is a known issues and the developer is still investigate this problem.

Could you try to install Nios II SBT v18.1 as workaround?

 

Thanks

0 Kudos
Highlighted
Novice
40 Views

Is the NIOS II SBT available as a separate download, or do you install all of 18.1 and use the SBT in it?

0 Kudos
Highlighted
Employee
40 Views

Hi, 

Could you try the steps as below:

 

1. Window search> turn window features on or off> enable Window Subsystem for Linux

2. Restart the computer

3. Go to Microsoft Store install -Ubuntu

4. Open Ubuntu and type the following command: 

  -sudo apt install wsl 

  -sudo apt install make 

  -sudo apt install dos2unix

 

For more information, you may need to chapter 2.1 in link below: 

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/nios2/n2sw_nii5v2gen2.pd...

 

Thanks

0 Kudos
Highlighted
Novice
40 Views

Hello,

 

I am running "real" Ubuntu, not the WSL version. No Windows on the computer, and no need to enable Linux - my system boots Ubuntu 18.04 LTS.

 

The make system and dos2unix were already installed. (dos2unix is just a text format / end of line changer)

 

Installing WSL in "real" Ubuntu causes the libxml2-utils package to be installed - and I think that this is what fixed it.

 

  • I can now start eclipse from the Quartus tools menu.
  • Running 'eclipse-nios2' from the command line starts eclipse - it no longer core faults.

 

This is with Quartus 18.1.1 - I can't use 19.1 until the JTAG-UART is fixed.

 

Thank you.

 

My original question remains: Can the SBT be downloaded separately, or must the full Quartus package be downloaded?

0 Kudos
Highlighted
Employee
40 Views

Hi,

 

Upon checking in https://fpgasoftware.intel.com/19.1/?edition=pro&platform=windows, the SBT could not download seperately and it is included in Quartus Prime package.

Sorry for make confusion.

 

Thanks

 

0 Kudos
Highlighted
Partner
40 Views

谢谢,该问题已经解决。

0 Kudos
Highlighted
Employee
40 Views

Hi,

Thank you for your information.

Thanks

0 Kudos