Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12600 Discussions

DE0-Nano Interrupts/Kernel Issues




As the title states, I am trying to get an interrupt signal from the FPGA->HPS. I know that I need to write a kernel driver module and register it to the interrupt, as well as updating the device tree based on the forum thread here: I was following along fairly well. However, I have been using the GHRD yocto linux image on the board thus far, and can't find the source for the kernel in order to compile modules against it. I found the rocketboards github and tried to use the 3.13 version, but when I compiled my code against it and tried to add the module to the board, I got:

fpga_uinput: version magic '3.13.0 SMP mod_unload ARMv7 p2v8 ' should be '3.13.0-00298-g3c7cbb9-dirty SMP mod_unload ARMv7 p2v8 ' Error: could not insert module fpga_uinput.ko: Invalid module format

So apparently that wasn't the correct version of the kernel. I then tried to just use the newest kernel on the rocketboards git. But after compiling it to the zImage it would always get hung-up when trying to boot the board but not always in the same spot. I'd appreciate any help thanks!

0 Kudos
0 Replies