Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12612 Discussions

DE1-SoC board: which defconfig, .dtb file, and sources shall I use best?

Altera_Forum
Honored Contributor II
1,155 Views

Hi, 

I have Terasic's DE1-SoC board and currently play around with the provided SD-card image, a self compiled kernel, my module and an FPGA .rbf which I would like to flash from the linux running on the SD card.  

 

My situation is the following, with the correct MSEL setting (00000) and the default SD-card image, I can dd the .rbf to /dev/fpga0 and the FPGA works correction i.e. some LEDs start to blink. Since I like to play with my own written kernel drivers, instead of the provided 3.12.0 zImage, I compile a 3.17 zImage. After trying several sources, among others rocketboards sources for the sockit board - the mainline kernel.org's worked best. I simply exchanged the zImage on the SD-card partition. When trying to build the .dtb my first question poped up: when doing "make dtbs" I can see socdk.dtb, sockit.dtb and the socrates.dtb being build as socfpga_cyclone5_xxx.dtb files. By playing around I ended up with the sockit.dtb. Now I have still the problem, that with such kernel, I can't do dd to /dev/fpga0 anymore, it simply does not blink as it should. 

 

Questions:  

1) is there a defconfig for the de1-soc board from terasic, or is socfpga_defconfig the correct one? 

 

2) I have some doubts about the usage of the correct device tree, which .dtb to use? Is there a terasic .dtb file somewhere? Or even may I best use the original socfpga.dtb from the sdcard and simply just exchange the zImage (I don't wan't to mess around with device trees actually)? 

 

3) how can I get a self compiled kernel to run which allows for flashing the fpga .rbf file, it seems in my kernels, there isn't even a /sys/class/fpga-stuff... menu available, which .config option shall I look at when menu-configuring it? 

 

Thanks in advance!
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
443 Views

Hi FAB, 

 

I have the same problem. Did you find a solution?  

 

Thanks
0 Kudos
Reply