Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12627 Discussions

Downloading ELF Process failed- Nios II quartus 19.1


Hello, I have read threads about this issue but none of the proposed solutions solved my problem.


I'm facing issues when I tried to download the sw to the NIOS processor, the error message says Downloading ELF Process failed. I thought it was some mistake I had when creating the fpga project but I double check the design and it's good. I'm using the On-chip memory RAM for the NIOS II. I'm using the evaluation kit Cyclone 10GX from Intel.  

-compile the design with quartus 19.1 Eval Board
-Flash the SOF
-Try with NIOS II quartus 2018 and NIOS 2019 (to check if that was the problem)
-Create a new project and bsp template with Hello world Small
-Compile the Project 
-When in the Run configuration tab the message Connected system ID I tried with ignore mismatched ID and time stamp
-Run and error message:  Downloading ELF Process failed.
-Inside NIOS Command Shell try jtagconfig and I can see nios ii processor correctly detected.
-I followed this tutorial to disable the drivers signature Verification in windows 10  so I can use the quartus 19 blaster-II drivers
-I also  follow this Troubleshooting guide cause at the beginning the NIOS eclipse IDE on quartus 19 was not even starting
-I reinstall all the software and tools
0 Kudos
2 Replies



Did you install WSL?:


It may be due to WSL not being installed or with the design, can you try one of the design below:


I did a fresh Quartus and Nios II install, and install WSL and tried one of the design above, it is working fine.

0 Kudos


Any follow up from your side?

0 Kudos