Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12612 Discussions

HPS not responding to the commands with EDS command Shell for flash




We are facing the below error for the write through the HPS JTAG to QSPI flash connected.

Below are the prints:


$ quartus_hps -c 1 -o P qspiimage.img

Info: *******************************************************************

Info: Running Quartus Prime Programmer

  Info: Version 16.0.0 Build 211 04/27/2016 SJ Standard Edition

  Info: Copyright (C) 1991-2016 Altera Corporation. All rights reserved.

  Info: Your use of Altera Corporation's design tools, logic functions

  Info: and other software and tools, and its AMPP partner logic

  Info: functions, and any output files from any of the foregoing

  Info: (including device programming or simulation files), and any

  Info: associated documentation or information are expressly subject

  Info: to the terms and conditions of the Altera Program License

  Info: Subscription Agreement, the Altera Quartus Prime License Agreement,

  Info: the Altera MegaCore Function License Agreement, or other

  Info: applicable license agreement, including, without limitation,

  Info: that your use is for the sole purpose of programming logic

  Info: devices manufactured by Altera and sold by Altera or its

  Info: authorized distributors. Please refer to the applicable

  Info: agreement for further details.

  Info: Processing started: Fri Sep 21 14:52:06 2018

Info: Command: quartus_hps -c 1 -o P qspiimage.img

Current hardware is: USB-BlasterII [USB-1]

Found HPS at device 2

  Double check JTAG chain

HPS Device IDCODE: 0x4BA00477

AHB Port is located at port 0

APB Port is located at port 1

  Double check device identification ...

Warning: Overwrite detected IDCODE

Setup non-secure transaction ...

Boot Info: 1.8V QSPI Flash

Clock Select: 0

Start HPS Quad SPI flash programming ...

Initialize QSPI peripheral and flash controller ...

  Assuming QSPI controller system clock is 50Mhz

  QSPI controller baudrate setting: 32 (15)

Read Silicon ID of Quad SPI flash ...

Error: Fail to poll the QSPI Command execution status

Error: Fail to read Silicon ID

Error: Quartus Prime Programmer was unsuccessful. 0 errors, 0 warnings

  Error: Peak virtual memory: 4270 megabytes

  Error: Processing ended: Fri Sep 21 14:52:07 2018

  Error: Elapsed time: 00:00:01

  Error: Total CPU time (on all processors): 00:00:00


We were able to program the same 2days back and all of a sudden it started giving this error.!! (Though there was some issue with the JFFS2 FS mounting)


From the above errors, could you please let us know what could be the issue?

Meanwhile we checked the clock,data& chip select pins during the command execution and we were surprised to see that these were not at all responding. Though they are toggling nicely when I give a hard reset from the reset switch connected to the HPS POR pin.


At present we have a single board and its a custom board. So we do not have the working copy/working captures of the QSPI clock,chip select and data to compare with. (we are running the 16.0 EDS command shell for QSPI program through JTAG & We are doing the FPGA configuration separately with EPCQL, File is generated from the same FPGA project, We have also tried just erase command {quartus_hps -c 1 -o E}, we are using the same tested flash from micron, MT25QU01GBBB8E12-0SIT, The boot select pins are fine and working proper{as we see some signals toggling for QSPI interface with reset}, Hardware point of view, we see proper voltages on the voltage rails)


Can anyone please help.


Thanks & Regards,

Nanjunda M

0 Kudos
4 Replies

Hi NanjundaM,

What FPGA device are you using?


Thank you.


0 Kudos

Hi Calvin,

Arria10 SOC - 10AS048H3F34I2



Nanjunda M

0 Kudos


There is a failure in reading the silicon ID of the QSPI device.

There might be a chance of failure to sync with this flash.


Can you try this option:



Also, can you try reducing the speed of USB blaster II ?



0 Kudos



We have already tried boot=18 command. Yet the result was same.

I'll check reducing the JTAG frequency too.


Thanks & Regards,

Nanjunda M

0 Kudos