Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12620 Discussions

Install older version of GCC compiler for HLS

Altera_Forum
Honored Contributor II
1,290 Views

I'm following the intel® high level synthesis compiler getting started guide for the Linux version it states that GCC compiler must be version 4.4.7 and newer ones are not supported. 

 

I'm running Ubuntu 16.04 LTS and gcc version is 5.4.0.  

 

How can I install the 4.4.7 version? 

 

Thank you.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
527 Views

I have installed it from Ubuntu trusty repositories. I don't know if this is the optimal solution but it worked. 

 

edit the apt sources file: sudo nano /etc/apt/sources.list 

 

add the trusty repo at the end: deb http://us.archive.ubuntu.com/ubuntu/ trusty universe 

 

reload the sources: sudo apt-get update 

 

install gcc 4.4: sudo apt-get install gcc-4.4
0 Kudos
Reply