Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12622 Discussions

Linux boot runs application differently to command line

Altera_Forum
Honored Contributor II
1,125 Views

Hi, 

I'm running linux 3.10.87-ltsi on a Cyclone V. 

I have an application that starts multiple threads, and changes the priority on some of these as well. It also loads two kernel drivers to give me access to a GPIO interrupt and contiguous memory for FPGA access. 

 

All of these load and run fine, if I run them from the ssh shell. 

However, if I run them from a script that systemd runs at boot time, then although the drivers load correctly, and the threads priorities get set correctly the application itself doesn't seem to run at the same performance level - ie we get data loss. 

 

Is there any trick to persuading linux to run the application as if it were run from the command line once boot had finished? 

 

Or any hints as to what I should watch for when starting applications during boot? 

 

Regards, 

Simon
0 Kudos
0 Replies
Reply