Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12618 Discussions

SEVERE: Setting does not exist for BSP: "hal.linker.enable_exception_stack".

DemirSezer
Beginner
814 Views

Hello,

 

I have tried to generate BSP with .sopcinfo file by using;

File -> New -> NiosII Board Support Package

 

 and get the error:

SEVERE: Setting does not exist for BSP: "hal.linker.enable_exception_stack".
SEVERE: java.lang.RuntimeException: Setting does not exist for BSP: "hal.linker.enable_exception_stack".
SEVERE: nios2-bsp-create-settings failed.

 

What may be the reason of this error and how can I solve it?

 

Thanks,

0 Kudos
8 Replies
KellyJialin_Goh
Employee
801 Views

Hi,

Kindly check out this link: https://www.intel.com/content/www/us/en/docs/programmable/683525/21-3/creating-a-new-bsp.html

You could create, edit and generate BSP using BSP editor and import as NIOS II software Build Tools project with the .sopcinfo file.

Thank you.


Regards,

Kelly Jialin, GOH


0 Kudos
DemirSezer
Beginner
778 Views

Hello,

Thanks for reply. I checked the link and these are the errors I encountered. Are there any solutions?

BSP_editor.JPG

Thanks,

0 Kudos
KellyJialin_Goh
Employee
769 Views

Hi,

Did you try to create, edit and generate BSP using BSP editor and import as NIOS II software Build Tools project with the .sopcinfo file?


Thank you.

Regards,

Kelly


0 Kudos
DemirSezer
Beginner
760 Views

Hello, 

 

I tried your advice and it didn't work. This is what I get when I tried to crate BSP with .sopcinfo file,

 

Errors.JPG

However, when I try to generate the BSP with.sopcinfo file using the version 12.0, I achieved it but this didn't solve my problem since I can't generate the same .elf file which is generated before. Sizes of the .elf files don't match so I want to build project in 10.1 version. I observed that there is something wrong in linker section of version 10.1 and that is what I suspect to be the reason but couldn't solve it. These are the images from 10.1 and 12 respectively with same .sopcinfo file.

 

Linker.JPG

Linker12.1.JPG

0 Kudos
KellyJialin_Goh
Employee
735 Views

Hi,

Here is a link for more information when you use the 10.0 version https://www.intel.com/content/www/us/en/support/programmable/articles/000077276.html


More details can be found here in the 'Linking and location' section regarding the error message that you posted.


I would suggest you compile your files with a newer Quartus version (17.0 and above) to reduce errors.

Thank you.


Regards,

Kelly


0 Kudos
KellyJialin_Goh
Employee
710 Views

Hi,

Any updates from your side whether the error has been solved?


Thank you.

Regards.

Kelly


0 Kudos
KellyJialin_Goh
Employee
698 Views

Hi,

Any updates from your side regarding the linker issue?


Regards,

Kelly


0 Kudos
KellyJialin_Goh
Employee
684 Views

Hi,

As we do not receive any response from you on the previous reply that we have provided. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


Thank you.

Regards,

Kelly Jialin, GOH


0 Kudos
Reply