Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12622 Discussions

Suspended: Signal 'SIGTRAP' at ecps base address

Honored Contributor II



This happen on two hardware platform with ucosII operation system. 

Last information is below: 

Suspended: Sigmal 'SIGTRAP' received. Description: Trace/breakpoint trap. 

1 <symbol is not available> 0x????????(ecps flash base address) 


One hardware configuration open UART receive timeout interrupt, running sometime later, system break at this information. 

So, first hardware close UART timeout interrupt, and software is polling to read uart each 1 second. And then it run ok. 


Another hardware configuration use self define hardware with 41 UART port, running is ok. But, if write a block flash after disable all interrupt, system break at this. 

Thus, I shield disable all interrupt before writing one block flash, system run ok.(But I know it's wrong, because the process of writing flash can't be interrupted.)  


I don't know why this happen. 

Which one could tell me how to find reason. 

0 Kudos
2 Replies
Honored Contributor II

Dear p5636231 

I have the same problem with you,having troubled me near a month,has your problem solved?could you give me some ideas? 

Thread [0] (Suspended: Signal 'SIGTRAP' received. Description: Trace/breakpoint trap.)  

1 <symbol is not available> 0x00000114  

waiting for your reply and best wishes tou you&#65281;
0 Kudos
Honored Contributor II




I have some issues to debug a project based on stratixIII_3sl150. I think that my problem is similar to yours problems. 


My problem is: 

The execution of my program (c/c++) in visual studio is fine and its build in niosII is fine. 

When i launch the debug in niosII, the project starts give results but it is suspended without finish the execution of the program. It mentions: 



- Thread [0] (Suspended: Signal 'SIGTRAP' received. Description:Trace/breakpoint trap.)  

1 <symbol is not available> 0x080000a0  



Please can you help me. 

How are you solved yours problems. 

0 Kudos