Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++

uClinux on Altera DE1 Board

Honored Contributor II



I was trying to run uClinux on a Altera DE1 Board development board. I started by trying to use "DE1 SD Card Audio.sof" and "ZImage DE1 SD Card Audio v0.6", as described on the following page. I could see the system booting through nios-terminal when I did this. 


Next, I tried to build the system myself to achieve the same. 


I used "Quartus II 12.1 Web Edition" to build by sof file as described by Mahdi Hafezi, on following YouTube video. 


Next, I downloaded the Virtual Machine available from below URL, and used the toolchain included in that VM. I still used the instructions as described by Mahdi Hafezi. 


I did get a zImage from this process and I could use "nios2-download -g zImage" to download the image to the board. Also the verification stage was ok after the download. However, when I used the command "nios2-terminal" I could not see the system booting. Basically there was no output at all. If I left the terminal open for a couple of minuets I did get some random characters on the terminal. 


I also tried connecting to the board's serial port while running "nios2-terminal" command, but nothing appeared on the serial port terminal as well. 


I was wondering if I'm doing something incorrect here, and wanted to ask if some cone could kindly guide me in the right direction. 


Thanks in advance for your kind assistance.
0 Kudos
0 Replies