Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bartłomiej_W_
Beginner
55 Views

Code Builder not initialized

Hello,

I just installed Intel® SDK for OpenCL* Applications 2016, and for both VS 2013 and VS 2015 I am getting this error:

Code Builder not initialized.

Unable to load DLL 'KernelBuilderAPI.dll': the specified procedure could not be found. (Exception from HRESULT: 0x8007007F).

I tried repairing the installation, then uninstall and reinstall, each time restarting the machine. I did quit all the applications that the setup wanted me to. Nothing helped. KernelBuilder.API.dll is of course present in the c:\Program Files (x86)\Intel\OpenCL SDK\bin\x64\ and c:\Program Files (x86)\Intel\OpenCL SDK\bin\x86\ directories. 

Any suggestions?

0 Kudos
4 Replies
Robert_I_Intel
Employee
55 Views

Hi Bartłomiej,

Which OS are you using? Which processor?

I experienced similar problems on Windows 8.1 running on 3rd generation Intel(R) Core processors. If that's what you have, I suggest fully uninstalling Intel® SDK for OpenCL* Applications 2016 and then trying the previous versions. On some machines, you need to downgrade the graphics driver to the previous version available here https://downloadcenter.intel.com/product/81499/Intel-HD-Graphics-4000-for-3rd-Generation-Intel-Core-...

Let me know if these suggestions worked for you.

Bartłomiej_W_
Beginner
55 Views

Thanks. I am running Windows 10 on Dual Xeon X5680, nVidia Quadro K5200 as the GPU. 

I'll check the 2015R3, but the whole point is to have VS 2013 and possibly VS 2015 integration. 

Bartłomiej_W_
Beginner
55 Views

Unfortunately, the issue is the same with 2015R3.

mao__eric
Beginner
55 Views

I also met this problem . My cpu is i5-3210M @2.5G and the gpu is HD Graphics 4000. ,system is win10 64bit VS2012.

When launch the vs2012 report error about can't load dll 'KernelBuilderAPI.dll.  So i add path "c:\Program Files (x86)\Intel\OpenCL SDK\bin\x64\ " to project setting. and the opencl sample BitonicSort can run correct.