OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU.
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1698 Discussions

Disable TBB on CPU fallback

Alexander_Herz
Beginner
435 Views

Hi,

I have a slightly obscure problem :) For testing purposes we're running opencl inside a linux VM, so the actual gfx hardware is not accessable. We're using the CPU fallback from intel's opencl impl instead. Apparently, this impl is using TBB to get better performance but our environment does not allow for third parties to create any threads. We don't need any performance, just that it works at all. Is there a way (maybe by setting an environment variable) to disable the multi-threading inside intel's CPU based opencl driver?

Thx, Alex

0 Kudos
6 Replies
Raghupathi_M_Intel
435 Views

I believe that's not possible. You may be able to play with global and local sizes to restrict the number of threads but the runtime still depends on tbb. I will fwd your question to see if there are workarounds.

Raghu

0 Kudos
Raghupathi_M_Intel
435 Views

Ok. Looks like there is no way to disable TBB.

0 Kudos
Yuri_K_Intel
Employee
435 Views
Hi Alexander, Is it possible to adjust VM settings so it uses only 1 core (without HT)? Probably this will prevent TBB from creating new threads. Thanks, Yuri
0 Kudos
Maxim_S_Intel
Employee
435 Views
0 Kudos
Alexander_Herz
Beginner
435 Views

Great, immidate exec seems to fix my problem.

I assume the standard TBB ENV vars also work here?

Regards,

Alex

0 Kudos
Raghupathi_M_Intel
435 Views

Thanks Max. I wasn't aware of the extension. Moreover I misunderstood the question as "completely disabling tbb".

0 Kudos
Reply