OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Intel Code Builder for OpenCL API -Error!

Lu__Shan
Beginner
417 Views

Hi,

    I have installed

1-system_studio_2019  

2-intel_sdk_for_opencl_2017_7.0.0.2568_x64 

3-Compute Runtime 4 packages:gmmlib ig-core igc-opencl opencl

4-l_opencl_p_18.1.0.013

5-SRB 5.0 : 3 packages

But I still got  Screenshot from 2018-11-20 17-37-07.png

And my laptop is i7-6500U

and the result of sys_analyzer_linux.py  is :

shan@shan-ZHAOYANG-E51-80:~/Music/OpenCL_Open_Intel$ sudo python sys_analyzer_linux.py 
--------------------------
Hardware readiness checks:
--------------------------
 [ OK ] Processor name: Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
--------------------------
OS readiness checks:
--------------------------
 [ OK ] GPU visible to OS
--------------------------
Media Server Studio Install:
--------------------------
 [ ERROR ] user not in video group.  Add with usermod -a -G video {user}
 [ ERROR ] libva.so.1 not found.  Check LD_LIBRARY_PATH contains '/usr/lib64;/usr/local/lib'
 [ ERROR ] libva not loading Intel iHD
 [ ERROR ] vainfo not reporting codec entry points
 [ ERROR ] no libva include files.  Are Intel components installed?
--------------------------
Component Smoke Tests:
--------------------------
 [ ERROR ] no Media SDK include files.  Are Intel components installed?
 [ OK ] OpenCL check:platform:Intel(R) OpenCL GPU OK CPU OK
platform:Experimental OpenCL 2.1 CPU Only Platform GPU OK CPU OK

 

 

Thanks 

0 Kudos
3 Replies
Lu__Shan
Beginner
417 Views

Back again,

    When I unistalled SRB5.0 and SDK 2017. It still got that error. And I found the PATH seems not correct. Because I don't find have the folder “opencl-intel-tools” but I have “opencl-intel-runtime” folder and it showed below.

I have read https://software.intel.com/en-us/openclsdk-devguide-configuring-the-intel-code-builder-for-opencl-api-plug-in-for-eclipse. But I think I used System Studio and SDK2019 stand alone version still not released yet. If I should set the PATH, which is that?

Thanks...

.
├── licensing
│   ├── DPD_EULA.txt
│   ├── redist.txt
│   └── Third_party_lic.txt
├── linux
│   ├── compiler
│   │   └── lib
│   │       ├── clbltfnshared.rtl
│   │       └── intel64_lin
│   │           ├── clbltfne9_img_cbk.o
│   │           ├── clbltfne9_img_cbk.rtl
│   │           ├── clbltfne9.rtl
│   │           ├── clbltfnh8_img_cbk.o
│   │           ├── clbltfnh8_img_cbk.rtl
│   │           ├── clbltfnh8.rtl
│   │           ├── clbltfnl9_img_cbk.o
│   │           ├── clbltfnl9_img_cbk.rtl
│   │           ├── clbltfnl9.rtl
│   │           ├── clbltfnz0_img_cbk.o
│   │           ├── clbltfnz0_img_cbk.rtl
│   │           ├── clbltfnz0.rtl
│   │           ├── cl.cfg
│   │           ├── libclang_compiler.so
│   │           ├── libcl_logger.so
│   │           ├── libcommon_clang.18.1.so
│   │           ├── libcpu_device.so
│   │           ├── libintelocl.so
│   │           ├── libOclCpuBackEnd.so
│   │           ├── libOpenCL.so -> ./libOpenCL.so.1
│   │           ├── libOpenCL.so.1 -> ./libOpenCL.so.2.0
│   │           ├── libOpenCL.so.2.0
│   │           ├── libtask_executor.so
│   │           ├── libtbbmalloc.so -> ./libtbbmalloc.so.2
│   │           ├── libtbbmalloc.so.2
│   │           ├── libtbb.so -> ./libtbb.so.2
│   │           ├── libtbb.so.2
│   │           ├── __ocl_svml_e9.so
│   │           ├── __ocl_svml_h8.so
│   │           ├── __ocl_svml_l9.so
│   │           └── __ocl_svml_z0.so
│   └── etc
│       └── intel64.icd
├── uninstall
│   ├── 32e
│   │   ├── gcc-3.2
│   │   │   └── libstdc++.so.5
│   │   ├── imageformats
│   │   │   └── libqjpeg.so
│   │   ├── install
│   │   ├── install_gui
│   │   ├── libcrypto.so.1.0.0
│   │   ├── libISSASecureWebChannel.so
│   │   ├── libISSASoapMessenger.so
│   │   ├── libssl.so.1.0.0
│   │   ├── libsv.so
│   │   ├── libz
│   │   │   ├── libz.so -> libz.so.1.2.11
│   │   │   ├── libz.so.1 -> libz.so.1.2.11
│   │   │   └── libz.so.1.2.11
│   │   ├── platforms
│   │   │   └── libqxcb.so
│   │   └── qt
│   │       ├── libQt5Core.so -> libQt5Core.so.5.6.2
│   │       ├── libQt5Core.so.5 -> libQt5Core.so.5.6.2
│   │       ├── libQt5Core.so.5.6 -> libQt5Core.so.5.6.2
│   │       ├── libQt5Core.so.5.6.2
│   │       ├── libQt5DBus.so -> libQt5DBus.so.5.6.2
│   │       ├── libQt5DBus.so.5 -> libQt5DBus.so.5.6.2
│   │       ├── libQt5DBus.so.5.6 -> libQt5DBus.so.5.6.2
│   │       ├── libQt5DBus.so.5.6.2
│   │       ├── libQt5Gui.so -> libQt5Gui.so.5.6.2
│   │       ├── libQt5Gui.so.5 -> libQt5Gui.so.5.6.2
│   │       ├── libQt5Gui.so.5.6 -> libQt5Gui.so.5.6.2
│   │       ├── libQt5Gui.so.5.6.2
│   │       ├── libQt5Widgets.so -> libQt5Widgets.so.5.6.2
│   │       ├── libQt5Widgets.so.5 -> libQt5Widgets.so.5.6.2
│   │       ├── libQt5Widgets.so.5.6 -> libQt5Widgets.so.5.6.2
│   │       ├── libQt5Widgets.so.5.6.2
│   │       ├── libQt5XcbQpa.so -> libQt5XcbQpa.so.5.6.2
│   │       ├── libQt5XcbQpa.so.5 -> libQt5XcbQpa.so.5.6.2
│   │       ├── libQt5XcbQpa.so.5.6 -> libQt5XcbQpa.so.5.6.2
│   │       ├── libQt5XcbQpa.so.5.6.2
│   │       ├── libQt5Xml.so -> libQt5Xml.so.5.6.2
│   │       ├── libQt5Xml.so.5 -> libQt5Xml.so.5.6.2
│   │       ├── libQt5Xml.so.5.6 -> libQt5Xml.so.5.6.2
│   │       ├── libQt5Xml.so.5.6.2
│   │       ├── libxcb.so -> libxcb.so.1.1.0
│   │       ├── libxcb.so.1 -> libxcb.so.1.1.0
│   │       └── libxcb.so.1.1.0
│   ├── cpu_only_rt_prerequisites.cab
│   ├── images
│   ├── install.cab
│   ├── licenses
│   │   ├── libstdc++
│   │   │   └── readme-libstdc++.txt
│   │   ├── openssl
│   │   │   ├── license.txt
│   │   │   └── readme.txt
│   │   └── PYTHON
│   │       └── License-BEOPEN.com_v1.0.txt
│   ├── mediaconfig.xml
│   ├── phonehome.cab
│   ├── pset_standard_dialogs.cab
│   └── pset_user_stat.cab
├── uninstall_GUI.sh
└── uninstall.sh

18 directories, 88 files

 

 

 

Screenshot from 2018-11-21 11-00-35.png

 

Lu__Shan
Beginner
417 Views

How can I see the eclipse log? I have checked /tmp/iss_env*/eclipse.log, but is empty with nothing and my codebuilder in system studio definitely cann't run and reported error!

Thanks...

Lu__Shan
Beginner
417 Views

I tried to use eclipse to load codebuilder plug-in, the message is "Failed to update machine list: Could not load required libraries; please make sure to set the correct path under the codebuilder for opencl preference page". And at the Code Builder for OpenCL preference page. I have set OpenCL bin Directory "/opt/intel/opencl-sdk/bin" The Opencl Lib Directory is "/opt/intel/opencl-sdk/lib64". Still the same error.

Reply